About Running memory caching on debian / rapbian buster with OC 10.4.0 & PHP7.2 ( raspberry Pi3 )

Hello OC Group,

do anybody know a documentation running OC 10.4 on debian buster with PHP7.2 and memory caching?

I’m running OC on a raspberry pi for years and run into some troule during the latest updates.
Unfortunately I did not found a suitable documentation about the following steps, so I’ll bring some
informations together from various posts from various environments I found in the internet.

With the latest OC update, PHP7.0 isn’t supported anymore so I decided an update from jessie with PHP7.0 to buster with PHP7.2.
After the OS upddate apache2 and mariadb was not installed so I have to install these packages binaries manually.
I tried to login tp maria db and surprise my OC db was still present but apache log shows some errors regarding OC.

Next I reviewed these instructions for missing tasks awaring PHP7.2 should be used.
https://kifarunix.com/install-owncloud-server-on-debian-10-buster/

Hint: meanwhile there is a debian 10 repo so you can use this in owncloud.list:
deb https://download.owncloud.org/download/repositories/10.4/prod/Debian_10/ /

After apache log was clean I called my OC website and it shows just one line about redis (I used in the past) ist not installed or configurated.
I deleted my memcache config in /var/www/owncloud/config/config.php and “tataaa…” OC was back with all my files and configurtions but without memory caching.

After I reviewed these old instructions about memory cahing:
https://doc.owncloud.org/server/9.0/admin_manual/configuration_server/caching_configuration.html
I was looking for the binary packages in the repo and, what the hell, php-redis, php-memchached and php-apcu have just dedicated dependencies to PHP7.3.
In the result there are no suitable binaries for PHP7.2 in the repo.

After googling around sometime, I decided to compile the missing redis.so from source like this:
apt install php7.2-dev pkg-php-tools
pecl install redis
echo “extension=redis.so” > /etc/php/7.2/mods-available/redis.ini
phpenmod redis # name of ini file

php -m shows redis is enabled now.

I put back my redis config back to /var/www/owncloud/config/config.php
‘memcache.local’ => ‘\OC\Memcache\Redis’,
‘redis’ => array(
‘host’ => ‘localhost’,
‘port’ => ‘6379’,
),
‘memcache.locking’ => ‘\OC\Memcache\Redis’,

and, because I do not not know all the system dependencies, I rebooted by pi.
“Tataaa…” my redis memcache was also back on stage.

Did anybody found a documentation about this steps?

1 Like

Check that redis-server is installed:

dpkg -l | grep redis

Make sure that it is up and running:

systemctl status redis # Should show that it is running
ss -tulpen # Should show a redis process listening on port 6379
1 Like