Access OC remotely

Steps to reproduce

1.install OC
2.It’s work only in internal network
3.

Expected behaviour

i want to access remotely with real IP

Actual behaviour

nothig hapend

Server configuration

debian 11:

Web server:

MDB:

PHP 7.4.21:

**ownCloud version 10.8.0.4
fresh install

cd /var/www/
wget https://download.owncloud.org/community/owncloud-10.8.0.tar.bz2 && \
tar -xjf owncloud-10.8.0.tar.bz2 && \
chown -R www-data. owncloud


Hello. I recently installed my owncloud from this link: https://doc.owncloud.com/server/admin_manual/installation/quick_guides/ubuntu_20_04.html on debian 11 server. I was able to configure it, but unfortunately I access it only from the internal network, and I want to have access from the outside. I made a DMZ of the router to the internal IP. I added the real IP to the trusted domain file, but again without success. Please help.

I guess this is rather an issue with the router config (port forwarding). Maybe you might give more details on that?

1 Like

As I wrote, I made a DMZ-I opened all the ports. is not that. I used the owncloud quick guide

Hey,

based on the spare provided information i also think that this is more a network or similar related problem (router, port forwarding, dmz configuration, accessing wrong IP remotely) rather then an ownCloud issue.

To increase the chances that some one can help you with ownCloud unrelated problems i think you could give more details about your setup, the configuration and similar like already asked by @alfredb previously.

I think the additional information should also include more information / details about the:

“Nothing happened” is indeed not a very helpful description. Anyway, I’ll stop here. I prefer not to ask all over again.

2 Likes

Have you tried logging into the server remotely via SSH to confirm that the DMZ re-direction is working and that all ports are definitely open?

Have you tried loading a generic index.html page into the web server location to determine if that is accessible via your web server and that the web server is working?

Have you loaded a generic php test file into the web server location to determine that PHP is working?