Add apps option only missing in the files,not geting apps option


#1

Steps to reproduce

Expected behaviour

Tell us what should happen

Actual behaviour

Tell us what happens instead

Server configuration

Operating system:

Web server:

Database:

PHP version:

ownCloud version: (see ownCloud admin page)

Updated from an older ownCloud or fresh install:

Where did you install ownCloud from:

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/…

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';


Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration

Browser:

Operating system:

Logs

Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

#2

Posting a bare template without filling in anything cannot be any help to understand your problem.

Once again:


#3

Hi alfredb,

With the risk of hijacking this topic, I think I know what Manasa_V is trying to report as I am experiencing also missing the Market app.

I run Ubuntu server 16.04 and recently upgrade owncloud from
deb https://download.owncloud.org/download/repositories/stable/Ubuntu_16.04/ /
and the Market app has problems that disables it. This is the output from the failed integrity check:

Technical information
=====================
The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix
them.

Results
=======
- market
	- FILE_MISSING
		- README.md
		- lib/HttpService.php
		- lib/VersionHelper.php

Raw output
==========
Array
(
    [market] => Array
        (
            [FILE_MISSING] => Array
                (
                    [README.md] => Array
                        (
                            [expected] => b53ebb407cb90a5cf9e28463013f38e6aec3d39b4281187366e02b5fd014be144216a088fc50851635acc50cb71c92ad2407b21e8a4f3433b0f73a32ea066c97
                            [current] => 
                        )

                    [lib/HttpService.php] => Array
                        (
                            [expected] => f8803c93bcd45a0bda2eee8c33c510064d2524e531de991e94cf65bffefc5f2caba061070478a28a44a3d7bc2a8699cbd1f7ac949c972b5426374811a5ee8c7d
                            [current] => 
                        )

                    [lib/VersionHelper.php] => Array
                        (
                            [expected] => fa454a12d5f050c2f8d396aa39c52e736bcb4110cf2ff3c55215a09b1754ba568baef1cd810aa1ad060125f616e8fe6885f6820592408e8964186d683ef167c2
                            [current] => 
                        )

                )

        )

)

I tried to
apt-get --reinstall install owncloud-files
without success. Then I downloaded and unpacked owncloud-files and did also not see the files owncloud reports as missing, so I guess they’re truly missing. On top of this I regularly have debsums checking the md5sums of all installed packages and comparing them to those listed in the deb-files and it lists mismatch for the following files:

/var/www/owncloud/apps/market/appinfo/info.xml
/var/www/owncloud/apps/market/appinfo/signature.json
/var/www/owncloud/apps/market/js/market.bundle.js
/var/www/owncloud/apps/market/lib/Application.php
/var/www/owncloud/apps/market/lib/CheckUpdateBackgroundJob.php
/var/www/owncloud/apps/market/lib/Command/InstallApp.php
/var/www/owncloud/apps/market/lib/Command/UpgradeApp.php
/var/www/owncloud/apps/market/lib/Controller/MarketController.php
/var/www/owncloud/apps/market/lib/Listener.php
/var/www/owncloud/apps/market/lib/MarketService.php
/var/www/owncloud/apps/market/vendor/autoload.php
/var/www/owncloud/apps/market/vendor/composer/ClassLoader.php
/var/www/owncloud/apps/market/vendor/composer/autoload_real.php
/var/www/owncloud/apps/market/vendor/composer/autoload_static.php

This is my package info:

# apt show owncloud-files
Package: owncloud-files
Version: 10.0.10-1+1.1
Priority: optional
Section: devel
Maintainer: Juergen Weigert <jw@owncloud.com>
Installed-Size: 129 MB
Conflicts: owncloud (<= 9.01.99), owncloud-config-apache (<= 9.01.99), owncloud-server (<= 9.01.99)
Replaces: owncloud (<= 9.01.99), owncloud-config-apache (<= 9.01.99), owncloud-server (<= 9.01.99)
Download-Size: 40,1 MB
APT-Manual-Installed: no
APT-Sources: https://download.owncloud.org/download/repositories/stable/Ubuntu_16.04  Packages
Description: ownCloud - Server
 The owncloud-files package installs the codebase.
 Admins are advised to check for missing dependencies
 and configuration settings using owncloud online documentation and the occ tool.
 .
 .
 At the same time, ownCloud provides employees and end users anywhere,
 anytime access to the files they need to get the job done - via mobile apps,
 desktop sync clients, WebDAV clients and the web. With ownCloud, employees
 can easily view and share documents and information critical to the
 business, in a secure, flexible and controlled architecture - one that is
 consistent with IT policies, procedures and regulatory requirements.
 .
 For more information, visit www.owncloud.com

I have tried writing Juergen Weigert directly but don’t know if he has received my e-mail.

Please advice.

Cheers,
Søren


#4

Hey,

as an alternative i think you could also open a new issue at https://github.com/owncloud/core/issues


#5

Wasn’t sure where to report it as it looks like a problem purely with the deb-package, but now I’ve gone ahead and done it.