Admin personal settings are missing

I’am a new Owncloud user. I have installed Owncloud version 10.5 and everything is working fine (I can upload files, create users and so on)but I can’t see the personal settings on the admin page. I says that there is an internal server error. Can anybody help me here.
Best regards

Steps to reproduce

Expected behaviour

Tell us what should happen

Actual behaviour

Tell us what happens instead

Server configuration

Operating system:
centos 8
Web server:

PHP version:

ownCloud version: (see ownCloud admin page)

Updated from an older ownCloud or fresh install:

Where did you install ownCloud from:

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
paste the results into and puth the link here.

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.


If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/…

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';

Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration


Operating system:


Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log [ADMINEDIT: removed] here

#### Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log
c) …

You didn’t deliver any “real” information. I recommend starting with owncloud.log.


Hi Alfred
Here is the log…
Best regards

After a brief lookup in your log, more guessing:

The problem seems related to the language settings.

  • Which language do you have selected?
  • Is your PHP version matching ownclouds requirements?

Maybe it’s better if you work through the given Posting-template.


Hi again

  • I have set the language to danish. I have tried to change the language in Centos to english but it did not have any effect.
  • I have php version 7.4.13 installed

Thank you for helping me.
Best regards

I was referring to the language settings in owncloud. Have you selected danish there as well?

1 Like

no. how do I set the language?

in my version I see the menu on the left in danish and folders are in english.

I think there was a problem with the Danish translations in 10.5. I suggest to use English for now. If it’s a fresh installation, you can wait until 10.6 is released.
The problem was with the translation itself, so it’s possible to change the translation, but I don’t know what was the offending one


As jvillafanez already wrote, there is an issue with Danish language in 10.5 (see

So, in that release never use Danish as a language or apply the patch from the ticket above to your code base.

If you want to change the languages for any existing user from Danish to English, you can use the following command in your mariadb console:

UPDATE oc_preferences SET configvalue=‘en’ WHERE appid=‘core’ AND configkey=‘lang’ AND configvalue = ‘da’;

This will make the settings working again.


Thanks for the reply. I will focus on the language and try to change it to english.
Best regard

1 Like

Hi cortho
Thank you. I will try to use the command in Mariadb.
Best regards

1 Like

Hi Alfred
It was a language problem. I upgrade to version 10.6 and everything is working fine.
Best regards