After a reboot, issues getting owncloud ftp back online

Hello, we have a server that was setup by our previous sys admin - he left the firm but didn’t leave much notes on this - it’s hosting our ftp site. our ssl cert expried but we had to reboot to try and get it back on there

for the reboot, the url that is tied to it fails to load

ftp.domain
can’t even get to it via the ip address

is there something that we should look for to get that server back on track?

Thanks in advance

we can get to the linux portion through vshpere to work on elements that way just not sure where to start

Absolute first: Have you tried turning it off and on again?

Then: you need root access, either via vsphere console or SSH. If you don’t have the password there are guides out there on the internet:
https://wiki.archlinux.org/index.php/Reset_lost_root_password

Once you have root access you need to make sure the network is up and running. Depending on the distribution you have, this is configured differently.

To figure out the distro run: cat /etc/os-release

Then ensure that all the services, typically necessary for an ownCloud setup, are up and running:

  • apache
  • mysql
    Depending on how it is setup up, it could also require the following additional services:
  • nginx (instead of apache)
  • php-fpm
  • redis

You can check which services are enabled by running the following command:
systemctl list-unit-files | grep enabled

If you can’t find any of these services you might have a docker setup.

Check the logs, typically found in /var/log/.

This is not a proper technical term. Can you ping it? Can you reach the ports with telnet? Have you tried using curl? Or did you just use the browser?

If nothing of this makes sense to you I recommend to get professional help, as this is an ownCloud support forum we can only help with ownCloud specific problems, and can’t provide general tech-support.

1 Like

This post was flagged by the community and is temporarily hidden.