Build client HELP

Following the tutorial of the appendix A (https://doc.owncloud.org/desktop/2.1/building.html) i have a problem in step 5 of Windows Development Build:
erro

@REBERTH_KELVIN_SANTO 2.1 is super outdated. Please use 2.6 instructions. I’d also recommend to use the magic of Craft:
https://doc.owncloud.org/desktop/2.6/building.html#windows-development-build-with-kde-craft

1 Like

Thanks for the help buddy.

I have issue with step 3:

6

The log is below:
CMakeOutput.log (9.7 KB)

@REBERTH_KELVIN_SANTO Please link the full terminal output. Did you perform all Craft steps from the beginning?

im running craft now… its 55% complete…

later i tell if works

Alright… dont works…

i can use cmake GUI? how?

i try follow windows build without KDECraft… and result is:::

help :c

@REBERTH_KELVIN_SANTO please stop posting screenshots and please link to your full terminal output. (from KDE Craft approach, not the CMake GUI and the other stuff)

1 Like

michael, one more question:

How i can get the "full terminal output " of KDE?

it is in a log file?

Normally its enough to copy paste the text.
The important parts of that output for the cmake processes above would have been everything from the invocation until the process failed.

Hey buddy!!!

the reason of i can execute cmake -G “MinGW Makefiles” . on qtkeychain is why i use qt 5.1.1.2 (mingw 7.3.0 64 bits), when i install FULL open source qtcreator package (~30 GB)…

i can use cmake on qtkeychain but now i try cmake on client-build and i get the error:

C:>mkdir client-build

C:>cd client-build

C:\client-build>cmake -G “MinGW Makefiles” -DNO_SHIBBOLETH=1 …/client
– The C compiler identification is GNU 7.3.0
– The CXX compiler identification is GNU 7.3.0
– Check for working C compiler: C:/Qt/Tools/mingw730_64/bin/gcc.exe
– Check for working C compiler: C:/Qt/Tools/mingw730_64/bin/gcc.exe – works
– Detecting C compiler ABI info
– Detecting C compiler ABI info - done
– Detecting C compile features
– Detecting C compile features - done
– Check for working CXX compiler: C:/Qt/Tools/mingw730_64/bin/g++.exe
– Check for working CXX compiler: C:/Qt/Tools/mingw730_64/bin/g++.exe – works
– Detecting CXX compiler ABI info
– Detecting CXX compiler ABI info - done
– Detecting CXX compile features
– Detecting CXX compile features - done
CMake Warning (dev) at OWNCLOUD.cmake:6 (set):
implicitly converting ‘string’ to ‘STRING’ type.
Call Stack (most recent call first):
THEME.cmake:5 (include)
CMakeLists.txt:13 (include)
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at OWNCLOUD.cmake:22 (set):
implicitly converting ‘string’ to ‘STRING’ type.
Call Stack (most recent call first):
THEME.cmake:5 (include)
CMakeLists.txt:13 (include)
This warning is for project developers. Use -Wno-dev to suppress it.

– Build of crashreporter disabled.
– GIT_SHA1 0df624bfae54ae7fd7d440d43962cabb3dc34723
– Could NOT find INOTIFY (missing: INOTIFY_INCLUDE_DIR INOTIFY_LIBRARY_DIR)
– Could NOT find Sphinx (missing: SPHINX_EXECUTABLE)
– Could NOT find PdfLatex (missing: PDFLATEX_EXECUTABLE)
CMake Error at C:/Program Files/CMake/share/cmake-3.15/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
Could NOT find ZLIB (missing: ZLIB_LIBRARY ZLIB_INCLUDE_DIR)
Call Stack (most recent call first):
C:/Program Files/CMake/share/cmake-3.15/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
C:/Program Files/CMake/share/cmake-3.15/Modules/FindZLIB.cmake:115 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
CMakeLists.txt:161 (find_package)

– Configuring incomplete, errors occurred!
See also “C:/client-build/CMakeFiles/CMakeOutput.log”.erro.txt (2.2 KB)
CMakeOutput.log (69.3 KB)

Hi, is there any reason you are not using the suggested Craft?

1 Like

i have some problems with this method look at 9/14 of this topic:

looks like: “points to a valid phyton installation”;

Best regards,
Reberth

@EDIT

i try install again with Craft and result i have problem on “craft owncloud-client” step
:
ninja: build stopped: subcommand failed.
Action: compile for owncloud/owncloud-client:master FAILED
*** Craft all failed: owncloud/owncloud-client after 3 minutes 18 seconds ***
fatal error: package owncloud/owncloud-client all failed

So just pasting “error” won’t help

1 Like

sorry…

i have success with Craft method editing the CraftSettings.cfg

i dont know why, but the starts of line where specify path of Python27 starts with #

and the Ninja as compiler i set False not True

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)