Buster Serverupgrade - php7.3.x?

Hallo,

habe gerade meinen Server auf Debian 10 (buster) upgedatet, nun habe ich das Problem das Owncloud mitteilt:
This version of ownCloud is not compatible with PHP 7.3
You are currently running PHP 7.3.4-2.

Wie kann ich owncloud mittelen, benutze die 7.3er php Version?

Welche ownCloud Version hast du?

So genau weiß ich das gar nicht, wenn ich versuche via’ sudo -u www-data php occ -V’ in der Konsole die Version festzustellen, erhalte ich selbiges wie oben (not compatible)
Aber igegendwas im 10er Bereich.

Hello,

Debian 10 Buster ships PHP 7.3 but ownCloud (no matter the version) doesn’t support it yet.
I wouldn’t suggest you to downgrade Debian, but with PHP FPM you can run several PHP versions. You could install an “older” PHP version, like 7.2 which is supported, and configure your web server for ownCloud to go with PHP7.2. You might try this, I wouldn’t advise it fully since I never followed this tutorial, and I didn’t do test on Debian 10 yet. But it’s for you to have hints on how to save it :wink:

okay Danke, gibt es jemand der es erfolgreich am laufen hat

Kein Problem, well you can try it on a virtual machine with Debian 10 using virtualbox or qemu/KVM or anything dealing with virtual machines. The ideal would be to backup your current server and install it on a virtual machine to fully test the process.

I wouldn’t recommend running ownCloud on FPM, that’s almost as unsupported as running it on PHP 7.3.
I also wouldn’t recommend compiling PHP yourself.

What I would recommend is finding a repository that offers compiled binaries. I did a quick google, but because Debian 10 is still pretty new it’s hard to find information for it yet.

What I did find was a guide for Debian 9, which you should be able to adjust for Debian 10 by changing changing stretch to buster in the following line like so:

echo "deb https://packages.sury.org/php/ buster main" | sudo tee /etc/apt/sources.list.d/php.list  

I would perhaps give this a quick go in a local Debian 10 docker container to test if that works and then you can try to implement it on your server.
Let me know should you have any further questions.

Why?!

I was able to run it without any problems…

1 Like

Danke, habe kein Virtuell oder Container Möglichkeit. Habe gerade die HowTo aber mit buster durchgearbeitet, nun starte ich den Server gerade neu und hoffe das owncloud wieder funktioniert.

@eneubauer ownCloud works well with PHP FPM (it’s just a way to run PHP, could be mod PHP or whatever it makes no weird differences), I run many ownCloud instances (~ 70/80) on PHP FPM with PHP 7.2, no problem at all. It’s a good way to have multiple PHP versions on the same server without destroying everything at each PHP upgrade.

@gil It doesn’t take much time to install some, if my german understanding is correct, restarting the server won’t change anything to your main problem.

1 Like

Just because it is not supported. I usually prefer FPM installations over mod_php, last I heard is that ownCloud can have problems because of the different thread safety of FPM. This doesn’t mean you can’t do it, it might just mean that if you run into problems first thing support is going to tell you to switch to mod_php…

1 Like

@cs35 ja Sie haben recht es hat sich nach dem neustart nichts gändert, ok probieren wir mal FPM

@eneubauer I didn’t read anything about unsupported PHP FPM in the official documentation (check my previous post), they mention some specific configuration for PHP FPM but nothing odd. I prefer to increase security splitting services rather than having one monolithic software with mod_php, but it’s another topic.

@gil Alright, good luck ! Keep us up to date.

Wie hast du sicher gestellt, dass die richtige PHP version aktiviert war? Hast du die falsche Version vom System entfernt?

In /etc/apache2/mods-enabled/ sollte es ein Modul geben, welches die entsprechende PHP binary für mod_php läd. Sollte php7.2.load heißen. Hier hilft es eine PHP-Info-Datei in einem vom Webserver erreichbaren Verzeichnis zu installieren und die Datei mit einem Webbrowser aufzurufen.

Genauso muss die richtige Binary für die CLI in deinem Pfad liegen. Da empfiehlt es sich mal mit php -v und which php zu testen welche Version jetzt eigentlich ausgeführt wird.

He upgraded his Debian server (probably from Debian 9 Stretch, I doubt he upgraded from an older version) to Debian 10 Buster which ships directly PHP 7.3 (which then removed his earlier PHP), it’s why I recommended him to go with PHP FPM and install PHP 7.2 the time that ownCloud 10.3 comes out. It’s not the best solution but it should work as a “hotfix” in his situation, he can clean it all afterwards.

@eneubauer, habe es via sudo a2enmod php7.2 versucht. Aber mit php -v bleibt die 7.3er
@cs35, ja habe von Debian 9 auf 10 upgeradet

/etc/apache2/mods-enabled/
ls /etc/apache2/mods-enabled/
access_compat.load    authz_user.load  dnssd.load    mpm_prefork.conf  reqtimeout.load
alias.conf            autoindex.conf   env.load      mpm_prefork.load  rewrite.load
alias.load            autoindex.load   evasive.conf  negotiation.conf  setenvif.conf
auth_basic.load       cgi.load         evasive.load  negotiation.load  setenvif.load
authn_core.load       deflate.conf     fcgid.conf    php7.0.conf       socache_shmcb.load
authn_file.load       deflate.load     fcgid.load    php7.0.load       ssl.conf
authz_core.load       dir.conf         filter.load   php7.2.conf       ssl.load
authz_groupfile.load  dir.load         mime.conf     php7.2.load       status.conf
authz_host.load       dnssd.conf       mime.load     reqtimeout.conf   status.load

Well yes the upgrade has certainly removed your PHP 7.2.

Could you try these commands:

dpkg -l | grep -i php

It would show you current php packages on your server.

apt update; apt-cache search php

It would show you what you could install.

pkg -l | grep -i php
ii  libapache2-mod-php5                  5.6.30+dfsg-0+deb8u1                                              i386         server-side, HTML-embedded scripting language (Apache 2 module)
rc  libapache2-mod-php5filter            5.4.45-0+deb7u1                                                   i386         server-side, HTML-embedded scripting language (apache 2 filter module)
ii  libapache2-mod-php7.0                7.0.33-8+0~20190531121329.14+buster~1.gbpe7d4ff                   i386         server-side, HTML-embedded scripting language (Apache 2 module)
ii  libapache2-mod-php7.2                7.2.20-1+0~20190710.23+debian10~1.gbp2428c5                       i386         server-side, HTML-embedded scripting language (Apache 2 module)
ii  libapache2-mod-php7.3                7.3.7-1+0~20190710.40+debian10~1.gbp032aec                        i386         server-side, HTML-embedded scripting language (Apache 2 module)
ii  libfpdf-tpl-php                      1.2-2                                                             all          PHP library to use PDF templates with FPDF
ii  libfpdi-php                          1.4.1-1                                                           all          PHP library for importing existing PDF documents into FPDF
ii  libphp-adodb                         5.20.14-1                                                         all          ADOdb is a PHP database abstraction layer library
ii  libphp-jpgraph                       1.5.2-13                                                          all          Object oriented graph library for php
ii  php                                  2:7.3+69+0~20190215163918.1+buster~1.gbp7a0d03                    all          server-side, HTML-embedded scripting language (default)
ii  php-apc                              4.0.7-1                                                           all          APC User Cache for PHP 5 (transitional package)
ii  php-auth-sasl                        1.0.6-3                                                           all          Abstraction of various SASL mechanism responses
ii  php-bz2                              2:7.3+69+0~20190215163918.1+buster~1.gbp7a0d03                    all          bzip2 module for PHP [default]
ii  php-cli                              2:7.3+69+0~20190215163918.1+buster~1.gbp7a0d03                    all          command-line interpreter for the PHP scripting language (default)
ii  php-common                           2:69+0~20190215163918.1+buster~1.gbp7a0d03                        all          Common files for PHP packages
ii  php-curl                             2:7.3+69+0~20190215163918.1+buster~1.gbp7a0d03                    all          CURL module for PHP [default]
ii  php-fpdf                             3:1.8.1.dfsg-2                                                    all          PHP class to generate PDF files
ii  php-gd                               2:7.3+69+0~20190215163918.1+buster~1.gbp7a0d03                    all          GD module for PHP [default]
ii  php-gettext                          1.0.12-0.1                                                        all          transitional dummy package for php-php-gettext
ii  php-intl                             2:7.3+69+0~20190215163918.1+buster~1.gbp7a0d03                    all          Internationalisation module for PHP [default]
ii  php-mail                             1.3.0-1                                                           all          Class that provides multiple interfaces for sending emails
ii  php-mail-mime                        1.10.2-0.1                                                        all          PHP PEAR module for creating MIME messages
ii  php-mbstring                         2:7.3+69+0~20190215163918.1+buster~1.gbp7a0d03                    all          MBSTRING module for PHP [default]
ii  php-mdb2                             2.5.0b5-2                                                         all          database abstraction layer
ii  php-mdb2-driver-pgsql                1.5.0b4-2                                                         all          pgsql MDB2 driver
ii  php-mysql                            2:7.3+69+0~20190215163918.1+buster~1.gbp7a0d03                    all          MySQL module for PHP [default]
ii  php-net-smtp                         1.8.0-1                                                           all          PHP PEAR module implementing SMTP protocol
ii  php-net-socket                       1.0.14-2                                                          all          Network Socket Interface
ii  php-pear                             1:1.10.8+submodules+notgz-1+0~20190219091014.9+buster~1.gbp1a209a all          PEAR Base System
ii  php-pgsql                            2:7.3+69+0~20190215163918.1+buster~1.gbp7a0d03                    all          PostgreSQL module for PHP [default]
ii  php-php-gettext                      1.0.12-0.1                                                        all          read gettext MO files directly, without requiring anything other than PHP
ii  php-phpseclib                        2.0.14-1                                                          all          implementations of an arbitrary-precision integer arithmetic library
ii  php-tcpdf                            6.2.12+dfsg2-1                                                    all          PHP class for generating PDF files on-the-fly
ii  php-xml                              2:7.3+69+0~20190215163918.1+buster~1.gbp7a0d03                    all          DOM, SimpleXML, WDDX, XML, and XSL module for PHP [default]
ii  php-zip                              2:7.3+69+0~20190215163918.1+buster~1.gbp7a0d03                    all          Zip module for PHP [default]
ii  php5                                 5.6.30+dfsg-0+deb8u1                                              all          server-side, HTML-embedded scripting language (metapackage)
ii  php5-apcu                            4.0.7-1                                                           i386         APC User Cache for PHP 5
ii  php5-cgi                             5.6.30+dfsg-0+deb8u1                                              i386         server-side, HTML-embedded scripting language (CGI binary)
ii  php5-cli                             5.6.30+dfsg-0+deb8u1                                              i386         command-line interpreter for the php5 scripting language
ii  php5-common                          5.6.30+dfsg-0+deb8u1                                              i386         Common files for packages built from the php5 source
rc  php5-curl                            5.6.30+dfsg-0+deb8u1                                              i386         CURL module for php5
ii  php5-enchant                         5.6.30+dfsg-0+deb8u1                                              i386         Enchant module for php5
ii  php5-gd                              5.6.30+dfsg-0+deb8u1                                              i386         GD module for php5
rc  php5-imagick                         3.2.0~rc1-1                                                       i386         Provides a wrapper to the ImageMagick library
ii  php5-imap                            5.6.30+dfsg-0+deb8u1                                              i386         IMAP module for php5
ii  php5-intl                            5.6.30+dfsg-0+deb8u1                                              i386         internationalisation module for php5
ii  php5-json                            1.3.6-1                                                           i386         JSON module for php5
ii  php5-mcrypt                          5.6.30+dfsg-0+deb8u1                                              i386         MCrypt module for php5
ii  php5-memcache                        3.0.8-5                                                           i386         memcache extension module for PHP5
rc  php5-ming                            1:0.4.4-1.1                                                       i386         Ming module for php5
ii  php5-mysql                           5.6.30+dfsg-0+deb8u1                                              i386         MySQL module for php5
ii  php5-pgsql                           5.6.30+dfsg-0+deb8u1                                              i386         PostgreSQL module for php5
rc  php5-ps                              1.3.7-1                                                           i386         ps module for PHP 5
ii  php5-pspell                          5.6.30+dfsg-0+deb8u1                                              i386         pspell module for php5
ii  php5-readline                        5.6.30+dfsg-0+deb8u1                                              i386         Readline module for php5
ii  php5-recode                          5.6.30+dfsg-0+deb8u1                                              i386         recode module for php5
ii  php5-snmp                            5.6.30+dfsg-0+deb8u1                                              i386         SNMP module for php5
ii  php5-sqlite                          5.6.30+dfsg-0+deb8u1                                              i386         SQLite module for php5
ii  php5-tidy                            5.6.30+dfsg-0+deb8u1                                              i386         tidy module for php5
ii  php5-xmlrpc                          5.6.30+dfsg-0+deb8u1                                              i386         XML-RPC module for php5
ii  php5-xsl                             5.6.30+dfsg-0+deb8u1                                              i386         XSL module for php5
ii  php7.0                               7.0.33-8+0~20190531121329.14+buster~1.gbpe7d4ff                   all          server-side, HTML-embedded scripting language (metapackage)
ii  php7.0-bz2                           7.0.33-8+0~20190531121329.14+buster~1.gbpe7d4ff                   i386         bzip2 module for PHP
ii  php7.0-cli                           7.0.33-8+0~20190531121329.14+buster~1.gbpe7d4ff                   i386         command-line interpreter for the PHP scripting language
ii  php7.0-common                        7.0.33-8+0~20190531121329.14+buster~1.gbpe7d4ff                   i386         documentation, examples and common module for PHP
rc  php7.0-curl                          7.0.33-0+deb9u3                                                   i386         CURL module for PHP
ii  php7.0-gd                            7.0.33-8+0~20190531121329.14+buster~1.gbpe7d4ff                   i386         GD module for PHP
rc  php7.0-intl                          7.0.33-0+deb9u3                                                   i386         Internationalisation module for PHP
ii  php7.0-json                          7.0.33-8+0~20190531121329.14+buster~1.gbpe7d4ff                   i386         JSON module for PHP
ii  php7.0-mbstring                      7.0.33-8+0~20190531121329.14+buster~1.gbpe7d4ff                   i386         MBSTRING module for PHP
rc  php7.0-mysql                         7.0.33-0+deb9u3                                                   i386         MySQL module for PHP
ii  php7.0-opcache                       7.0.33-8+0~20190531121329.14+buster~1.gbpe7d4ff                   i386         Zend OpCache module for PHP
ii  php7.0-pgsql                         7.0.33-8+0~20190531121329.14+buster~1.gbpe7d4ff                   i386         PostgreSQL module for PHP
ii  php7.0-readline                      7.0.33-8+0~20190531121329.14+buster~1.gbpe7d4ff                   i386         readline module for PHP
ii  php7.0-xml                           7.0.33-8+0~20190531121329.14+buster~1.gbpe7d4ff                   i386         DOM, SimpleXML, WDDX, XML, and XSL module for PHP
ii  php7.0-zip                           7.0.33-8+0~20190531121329.14+buster~1.gbpe7d4ff                   i386         Zip module for PHP
ii  php7.2                               7.2.20-1+0~20190710.23+debian10~1.gbp2428c5                       all          server-side, HTML-embedded scripting language (metapackage)
ii  php7.2-cli                           7.2.20-1+0~20190710.23+debian10~1.gbp2428c5                       i386         command-line interpreter for the PHP scripting language
ii  php7.2-common                        7.2.20-1+0~20190710.23+debian10~1.gbp2428c5                       i386         documentation, examples and common module for PHP
ii  php7.2-curl                          7.2.20-1+0~20190710.23+debian10~1.gbp2428c5                       i386         CURL module for PHP
ii  php7.2-json                          7.2.20-1+0~20190710.23+debian10~1.gbp2428c5                       i386         JSON module for PHP
ii  php7.2-mbstring                      7.2.20-1+0~20190710.23+debian10~1.gbp2428c5                       i386         MBSTRING module for PHP
ii  php7.2-mysql                         7.2.20-1+0~20190710.23+debian10~1.gbp2428c5                       i386         MySQL module for PHP
ii  php7.2-opcache                       7.2.20-1+0~20190710.23+debian10~1.gbp2428c5                       i386         Zend OpCache module for PHP
ii  php7.2-readline                      7.2.20-1+0~20190710.23+debian10~1.gbp2428c5                       i386         readline module for PHP
ii  php7.2-xml                           7.2.20-1+0~20190710.23+debian10~1.gbp2428c5                       i386         DOM, SimpleXML, WDDX, XML, and XSL module for PHP
ii  php7.3                               7.3.7-1+0~20190710.40+debian10~1.gbp032aec                        all          server-side, HTML-embedded scripting language (metapackage)
ii  php7.3-bz2                           7.3.7-1+0~20190710.40+debian10~1.gbp032aec                        i386         bzip2 module for PHP
ii  php7.3-cli                           7.3.7-1+0~20190710.40+debian10~1.gbp032aec                        i386         command-line interpreter for the PHP scripting language
ii  php7.3-common                        7.3.7-1+0~20190710.40+debian10~1.gbp032aec                        i386         documentation, examples and common module for PHP
ii  php7.3-curl                          7.3.7-1+0~20190710.40+debian10~1.gbp032aec                        i386         CURL module for PHP
ii  php7.3-gd                            7.3.7-1+0~20190710.40+debian10~1.gbp032aec                        i386         GD module for PHP
ii  php7.3-intl                          7.3.7-1+0~20190710.40+debian10~1.gbp032aec                        i386         Internationalisation module for PHP
ii  php7.3-json                          7.3.7-1+0~20190710.40+debian10~1.gbp032aec                        i386         JSON module for PHP
ii  php7.3-mbstring                      7.3.7-1+0~20190710.40+debian10~1.gbp032aec                        i386         MBSTRING module for PHP
ii  php7.3-mysql                         7.3.7-1+0~20190710.40+debian10~1.gbp032aec                        i386         MySQL module for PHP
ii  php7.3-opcache                       7.3.7-1+0~20190710.40+debian10~1.gbp032aec                        i386         Zend OpCache module for PHP
ii  php7.3-pgsql                         7.3.7-1+0~20190710.40+debian10~1.gbp032aec                        i386         PostgreSQL module for PHP
ii  php7.3-readline                      7.3.7-1+0~20190710.40+debian10~1.gbp032aec                        i386         readline module for PHP
ii  php7.3-xml                           7.3.7-1+0~20190710.40+debian10~1.gbp032aec                        i386         DOM, SimpleXML, WDDX, XML, and XSL module for PHP
ii  php7.3-zip                           7.3.7-1+0~20190710.40+debian10~1.gbp032aec                        i386         Zip module for PHP
ii  phpmyadmin                           4:4.6.6-4                                                         all          MySQL web administration tool
ii  phppgadmin                           5.1+ds-4                                                          all          web-based administration tool for PostgreSQL

It’s weird you seem to still have some mod PHP 7.2 installed.

Could you try this command to check what’s currently loaded by Apache:

apache2ctl -M