Buster Serverupgrade - php7.3.x?

sudo apache2ctl -M
[Fri Jul 12 18:16:00.149735 2019] [so:warn] [pid 12305] AH01574: module php7_module is already loaded, skipping
AH00112: Warning: DocumentRoot [/var/www/nirvana] does not exist
Loaded Modules:
 core_module (static)
 so_module (static)
 watchdog_module (static)
 http_module (static)
 log_config_module (static)
 logio_module (static)
 version_module (static)
 unixd_module (static)
 access_compat_module (shared)
 alias_module (shared)
 auth_basic_module (shared)
 authn_core_module (shared)
 authn_file_module (shared)
 authz_core_module (shared)
 authz_groupfile_module (shared)
 authz_host_module (shared)
 authz_user_module (shared)
 autoindex_module (shared)
 cgi_module (shared)
 deflate_module (shared)
 dir_module (shared)
 dnssd_module (shared)
 env_module (shared)
 evasive20_module (shared)
 fcgid_module (shared)
 filter_module (shared)
 mime_module (shared)
 mpm_prefork_module (shared)
 negotiation_module (shared)
 php7_module (shared)
 reqtimeout_module (shared)
 rewrite_module (shared)
 setenvif_module (shared)
 socache_shmcb_module (shared)
 ssl_module (shared)
 status_module (shared)

funktioniert leider immer noch nicht, würde gern apt-get purge php7.3 los lassen?

Ich Glaube ein Stück weiter gekommen zu sein, zumindest erhalte ich jetzt folgende Meldung beim aufrufen von owncloud im Browser.

PHP-Modul zip nicht installiert.
Bitte frage, für die Installation des Moduls, Deinen Server-Administrator.
PHP-Modul intl nicht installiert.
Bitte frage, für die Installation des Moduls, Deinen Server-Administrator.
PHP-Module wurden installiert, werden aber als noch fehlend gelistet?
Bitte kontaktiere Deinen Server-Administrator und bitte um den Neustart des  Webservers.

Für diejenigen, die selbiges Problem haben, dieser tollen Anleitung hat mir geholfen:

Habe fertig, owncloud läuft endlich wieder. Vorher noch schnell die zwei Module
php7.2-zip
php7.2-intl
installiert den Apache Dienst restartet und fertig.

Hoffe nun die Umstellung von owncloud auf php7.3 zeitnahe mitzukommen, damit ich es wieder auf den Standard setzen kann.

Hello

Well the commands I gave you were only to check your configuration and know from where to begin.

So I’m assuming you did:

a2dismod php7.3
a2enmod php7.2

And also, for the cron to work correctly:

update-alternatives --set php /usr/bin/php7.2

Is that correct ?

One slight note, be carreful using ppa on Debian.

Ja genau,
mit ‘sudo ls /etc/apache2/mods-enabled/’ nachgeschaut welche Version von php aktiv waren, dann alle (ausser die 7.2er) via ‘sudo a2dismod phpX.X’ deaktiviert. Danach ‘sudo a2enmod php7.2’ ausgeführt und Sicherheitshalber auch bzw. dass, die 7.2er in der Konsole ausgeführt wird, ‘sudo update-alternatives --set php /usr/bin/php7.2’. Und am Schluss den apche via ‘sudo service apache2 restart’.

Zum Testen ein ‘php -v’ und die Konsole meldet brav, 7.2 ist aktiv und installiert.

1 Like