Can´t execute occ file and no web gui 'internal server failure' appears

Actual behaviour

Can´t execute occ file and no web gui ‘internal server failure’ appears.

Failure on consol:
bash-4.1$ ./occ
An unhandled exception has been thrown:
Error: Class ‘OCA\DAV\Connector\Sabre\Auth’ not found in /var/www/html/owncloud/lib/private/legacy/app.php:137
Stack trace:
#0 /var/www/html/owncloud/lib/private/Console/Application.php(99): OC_App::loadApps()
#1 /var/www/html/owncloud/console.php(105): OC\Console\Application->loadCommands(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
#2 /var/www/html/owncloud/occ(11): require_once(’/var/www/html/o…’)
#3 {main}bash-4.1$

I could not find anything about it on websearch.

Server configuration

Operating system:
Linux version 2.6.32-642.4.2.el6.x86_64

Web server:
nginx Version : 1.6.2

owncloud version : 10.1.0.4

Hey,

this looks to me that either your setup is incomplete (missing files) or that you have some old / incompatible apps installed / enabled.

For the apps topic i’m not sure how to gather and disable the apps which could be responsible for this. Maybe another user can jump in here and help?

Could be related to wrong PHP version.
Which php version are you running?

PHP version 7.1.26 is running

The setup was complete. We use it since 4 years. Last update was in january 2019.

When I disable the Entry: $davUser = \OC::$server->getUserSession()->getSession()->get(\OCA\DAV\Connector\Sabre\Auth::DAV_AUTHENTICATED);

and set $davUser=null

I can execute the “occ file”. Also I see the user web gui but at login I get the error “302 to many redirects”.

I´m a little bit confused because nothing changed on the server the last weeks.

Are you using Memcached or Redis? If yes, can you make sure it is accessible using the configuration from the config.php file (exact IP address, port, credentials…) ?
For Redis I would test with the following command on the CLI:

redis-cli -h 127.0.0.1 

Exchange 127.0.0.1 for whichever IP address is configured for your redis instance in the ownCloud config.php.

I know this is probably not very helpful right now, but Version 10.1.0 had some major issues and it is strongly recommended to upgrade.