Cannot open status.php

9.1.x

#1

Hello All,

I am trying to setup an owncloud on my RaspberryPi. To install everything I have followed the tutorial here.

However, when trying to start the configuration, I open https://[myIP]/status.php and the first time I did so, I was notified about the unsafe security certificate. I added an exception but the browser did not forward me to the welcome page. After a reboot of both the raspi running the owncloud server and the computer from which I try to access the cloud the issue still remains.

Steps to reproduce
1. Follow guide posted above
2. Try to open status.php
3. Add security exception in FF upon first try

Expected behaviour
Welcome screen for owncloud configuration should appear

Actual behaviour
Connection times out, FF just does nothing (no error code is shown)

Server configuration
Operating system:
Raspbian (NOOBS)

Web server:
Don't know

Database:
Don't know

PHP version:
5.6.29-0+deb8u1

ownCloud version (see ownCloud admin page):
9.1.0.15

Updated from an older ownCloud or fresh install:
fresh install

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):
None

EDIT: From ssh into Raspi found owncloud version
EDIT2: Move to Misc category


#2

Hi,
I don't know too much about RasberryPi but this looks more as a certificate problem than an Owncloud problem. Have you tried to connect using http rather than https?
Are you sure the certs are well installed, with all the chain exposed?


#3

Thank you for the quick reply.
I am not sure the certificates are correctly installed, but have tried removing the s from https in ff with the same effect. The page simply does not load at all.
How could I check if it is a certificate problem?


#4

Please move this thread into the https://central.owncloud.org/c/help/miscellaneous category as is not an issue of ownCloud itself but of your webservers configuration (ownCloud is just a web application written in PHP and served by your webserver. It can't cause timeouts / connection issues for your clients).


#5

I moved the thread this morning already, but now that I have some more time I would like to know if there is any ideas that you have which I could try to fix the issue?

If owncloud is only the application, then how come I do not get to see anything when trying to connect to the IP? Do I need to specify a port instead of status.php?

Also note that there is no timeout generated, the browser simply stops trying to connect after some time.