Cannot upload files larger than 2Gb

I just installed owncloud 9.1 on a ubuntu 16.04 server. I followed the instructions on this page:

Whenever I try to upload a file that is larger than 2Gb I get an error like "Error uploading file "four": Internal Server Error"

In the admin menu I changed the file size option to 60Gb. I did not help. I also tried changing the size directly on owncloud/.htaccess file. Same error.

I see no errors on owncloud.log file, or apache error log file. I also tried setting the logging level to all in the admin page. But saw no messages.

The apache server version is 2.4.18 and php version is 7.0 The database is a mysql server 5.6

What am I missing?

Please see the following resources for all known infos how to fix your environment to upload larger files:

I checked the link you suggested.

This fields are set to 60G.

php_value upload_max_filesize = 16G
php_value post_max_size = 16G

I am not using the mod_reqtimeout module. I dont have the LimitRequestBody set and I not using ssl. I am also, not using the mod_fcgid module. And I don't have rewrite rules configured.

Also make sure that you're using a 64bit system. But your mentioned stuff is only partially what could cause this. Please take some time and work your way completely through this resources.

I am sure I am using a 64 bit system.

Is there some other kind log I can enable to try to find the error? Or is there another way to upload the file to owncloud, that is not to use the interface?

I read somewhere in the docs I am not supposed to copy the files directly to the folder on the filesystem.

There is anothet faq about logfiles:

as well as another documentation: