Cant access some of my folders anymore

Also if I upload files via ftp, they wont show up in Owncloud anymore....

Have you tried telling it to rescan for new files?

sudo -u apache php console.php files:scan --all

That's the command I use on CentOS 7, it may be different depending on which operating system you use.

is there a way to trigger this via an url?
i uploaded the new files again via owncloud webinterface to have them available.

but my biggest problems is access to folders and files I had access before and now it tells me that I dont have any access anymore. I am even the only user on it. so it can't be assigned to another user by accident. How do I tell owncloud to get access back.
The files itself have the same permissions in linux like the files i can still access.

That's not the purpose. You said you've done multiple server upgrades, and you don't know when the issue first arose. This file rescan is something you do after an upgrade, to make sure all the content is available.

As with any technical forum, you're going to have to post output and data if you expect meaningful responses. You say the permissions are "the same" but how do we know how you've determined this? We have no idea what the permissions are set to, or whether they're even correct, or what the selinux labels are set to, or what your system sebools are set to. The more data you provide, the better.


with server upgrade I mean Owncloud server. not my hosting server.

yes i checked the permission with ftp and they are for folders rwxr-xr-x and for files rw-r--r-- and owner and group are correct as well.
this is the only user and group which can own files anyway on my setup.
I a saying they are correct, because the files and folders i still can access have the same permissions and owner and group.

the problem with your command is, i cant run anything requiering root.

I know i had issues before with utf8 formating and i was able to fix this in the sql database by altering the entries manually. Like owncloud has issues with ö ä u and so on in file and foldernames.

hope that helps...

Also if I upload files via ftp, they wont show up in Owncloud anymore....

This was never supported and cause issues like seen now:

^ Interesting, didn't know that either. Sounds like External Storage app is the way to go then, pointed at some local folder for FTPing files into.

Well this feature doesnt work now anymore, but thats how I got all my files into owncloud. I moved the already existing folder with my files to the ownlcoud directory. Weird. Anyway thats not a problem right now. Right now my problem is that I can't access certain areas of my owncloud installation :frowning:

Hi all,

I still would need some support on the initial issue. So what can I do to provide more information to solve this...

You need to be able to run that mentioned occ command as your webservers user to solve this.

Thats the only chance to update oC's filecache which got very likely broken by the mentioned and unsupported modifications within the datadir.

hi RealRancor,

i cant run any sudo commands. Its shared hosting. There must be another way. Is there no command I can run directly in the database with phpmyadmin?

Which unsuported modifications do you talk about? I am a bit lost here...

I still need help with this but support is very thin here.

As i mentioned i cant run any sudo commands because i am on shared hosting. Nobody can or want help? to bad.

RealRancor send you already a link that manually putting files is not supported. With webhosting, this is difficult to handle.

What you can try: Open the existing folder (as close as you can get in the file structure), then create a new textfiles, make little changes. This sometimes triggers to update the file-index of this specific folder. If that doesn't work, there is no other way than upload the files via webinterface, oc-client or webdav.

Hello guys. i wanna clarify some things.

its not about manually putting files. its about files and folders i have no longer access too but had bevore. this were not manually uploaded.

I had access to all this files and folders before. I dont know exactly when i lost the access because i dont access 20.000 files daily and check if they work. So i cant tell you when that happened. probably with one of the latest OC updates/upgrades.

All the files were in the database and I had access before. now i lost it to certain files. I cant get it back with manually creating the folder, because its already in the database that I (the one and only user of this installation) have no access to it. I think it needs to be fixed in the database rather than the actual filesystem on the server itself.

I had access to ALL my files and folders before and now I got restricted for whatever reason.

I started my owncloud by moving folders from an existing folder outside of OC wiht all my files into the OC data dir and OC created the database for all the files by itself. It worked perfectly and I had access to all the files on my OC. Now i have restrictions on certain files and folders. Well mainly the folder, because all the files are in a directory which I cant access anymore. So basically I just lost permission to see certain folders (including the files located within.)

Is there a manual way to reset the hole file cache or database to tell OC to start from scratch...

Thanks for that clarification. To put files manually via FTP into the data-folder is done by many users and statements like this

ring all alarm bells :wink:

Normally, that should not happen at all, default charset of php and mysql should be set to utf8. Could be related to your problem. It is difficult to find out the reason what has happened, perhaps a timeout (php, database)?

Yes with a new setup. The problem is you can't trigger a filescan, but even if you could, this would create a complete new file index, meaning all your sharing settings, file tags, .. are lost and the client needs to download all files again!

Running ownCloud on shared hosting comes with certain limitations. There were already thoughts about dropping the support completely:
Especially if you use a larger setup, I would recommend moving to a more suitable environmet, at least a vserver or some device at home (RPi3, Intel NUC, ...).

Hi tflidd,

thanks for your message. I dont care if I loose share settings, tags and so on. I am using OC as an easy way to access files from everywhere and everything.

Well this is the most suitable enviroment for me, because I have unlimited storage and I wont get that with any vserver or anything else. At least nothing I have found so far. Thats why my current setup is best for me. I dont need the performance for a lot of users. Its a single user system, sometimes I share some files and "delete" the share link again

About your timeout, that could be, but I dont know. But the timeout shouldnt matter, because the folders I can't access are already indexed or were indexed before.

Now my OC installation is kinda useless, if i cant access all the files.

The only way is to figure out, up to which size your webhosting can handle a owncloud installation. If you find any pattern why and when the file-index gets wrong, we can try to track the problem.

You can setup a new installation, only other way to fix it, you could migrate the whole setup to a local machine, run the repair commands, and then migrate it back to your webhoster.

If i set up a new installation on the server, can I somehow "move" my current data fodler to the new directory without uploading it again?

You can set your old storage-location as external storage and then copy the files.

hey, can you give me some more insights on that? so link another owncloud installation with the new owncloud?

or just change the data dir in the config file to my current location?