Can't login apart from the admin account

ldap
10

#1

Installed new server on ubuntu 16.04.

Installed the ldap app and configured it, tests from config area seem to work.

When i try to login with the one local user or any ldap users i get this;

Internal Server Error

The server encountered an internal error and was unable to complete your request.

Please contact the server administrator if this error reappears multiple times and include the technical details below in your report.

More details can be found in the server log.

Technical details

Remote Address: haproxy server
Request ID: VkkEuwiSS02YFOei9Zcz

The apache.lo shows;
[:error] [pid] 1657 script ‘/var/www/html/status.php’ not found or unable to stat
[:error] [pid] 1533 script ‘/var/www/html/remote.php’ not found or unable to stat

Attached my config reportconfig_report_20180809.txt (100.4 KB)owncloud.log.txt (985.9 KB)


#3

I see quite a bunch of “Redis server went away” error messages. Either disable redis or fix the problem.


#4

Disabled Redis and i’m still not able to login other than with the admin acct.


#5

could be that the admin acc is a local user, and the “other” are LDAP users.

Please check your LDAP configuration.
https://doc.owncloud.com for Information.


#6

Submit new logs with the redis configuration disabled in ownCloud. There should be more clues there.


#7

Here’s a new log file zipped
My ldap user is FC729BF1-DE23-4583-9E18-61C80B00A1F5 and i tried to login a few times.
Side note, users that have the desktop app are able to sync files but, not login either.

Thanks for your help

owncloudlog.zip.txt (67.7 KB)


#8

Try removing the account from ownCloud and then resync it. Maybe the data folder for the user wasn’t created properly.

There are also “unsupported client version” errors that you should check, but it doesn’t seem related to this problem.