Can't move files to other folders in web interface

hosting

#1

With a fresh install I wanted to move the manual pdf to the documents folder. But this don’ts work… I only get a spinnig wheel. When I refresh te page the file is still there. It also doesn’t work through webdav.

28

I enabled redis cache, added a cron job and using a mysql database which works fine.

Server configuration

Systemstatus
installed 1
maintenance
needsDbUpgrade
version 10.0.9.5
versionstring 10.0.9
edition Community
productname ownCloud

Database: mysql

PHP version: 7.2

What could be the problem?
I tried both google chrome and safari, none works…
Uploading works fine.

Thanks,
Michael


#2

how did you install ownCloud?


#3

Uploaded all the files through FileZilla (FTP, binary) to my server.


#4

Oh, I can’t move files through webdav either… “Method not allowed”
07


#5

please check the documentation and see if you skipped one step.

https://doc.owncloud.com/server/10.0/admin_manual/installation/source_installation.html


#6

Thanks,

But that doesn’t work either… I followed the installation instructions through the web interface. I added a couple of codes to the config file, but nothing more…

<?php
$CONFIG = array (
  'instanceid' => '**',
  'passwordsalt' => '***',
  'secret' => '***',
  'trusted_domains' => 
  array (
    0 => '***',
  ),
  'datadirectory' => '/home/***/domains/***/public_html/***/data',
  'overwrite.cli.url' => 'https://***',
  'dbtype' => 'mysql',
  'version' => '10.0.9.5',
  'dbname' => '***',
  'dbhost' => 'localhost',
  'dbtableprefix' => 'oc_',
  'dbuser' => '***',
  'dbpassword' => '***',
  'logtimezone' => 'UTC',
  'installed' => true,
  'session_keepalive' => true,
  'memcache.local' => '\OC\Memcache\Redis',
  'redis' => [
     'host' => '10.0.***',
     'port' => 216**,
     'password' => '***',
  ],
 'memcache.locking' => '\OC\Memcache\Redis', // Add this for best performance
);

Has this something to do on the server side? Or is it a setting in OwnCloud itself?

Thanks!


#7

have you done this:

https://doc.owncloud.com/server/10.0/admin_manual/installation/source_installation.html#configure-apache-web-server

and this:

https://doc.owncloud.com/server/10.0/admin_manual/installation/source_installation.html#additional-apache-configurations

also this is important:

https://doc.owncloud.com/server/10.0/admin_manual/installation/source_installation.html#run-the-installation-wizard

I would also try to comment out the memory cache / redis and see if the problem persists.


#8

Thanks,

But unfortunately I don’t have access to the server itself. It is something like shared hosting, but only for myself (so no other users on the same server).

That’s why I can’t change specific things on the server itself.

Is it not something with file permissions?


#9

Also, I copied the files with filezilla to the web server. Followed the online setup and added a couple of lines for redis coache to the config file.

I redid it all together (new database and redis cache), but nothing works…


#10

So you don’t have admin access?


#11

Not entirely, no. Just DirectAdmin and that’s it. I can’t restart the server, but can change some php settings.


#12

Well, how you then expect that I help you? :slight_smile:

I suspect that some modules have not been installed or configured, that’s why you are having issues.

I have linked the required steps in my post above.

I could be wrong, in that case maybe someone else from the community will help you.

Also you could look at the owncloud.log and see if you find some clues.


#13

Because I thought it would be a permission issue, because everything else works except moving files…

But thanks for your help!


#14

From your screen shot I thought that you could not move files in your own ownCloud directory.

If you access a shared folder or something like that, where someone would give you permissions - that could be an permissions issue. That you don’t have write but read permissions.


#15

Hey,

could it be possible that your web server is not allowing the required HTTP method for moving files?


#16

Could be. Is it something I can enable?

If it’s something else, I can ask my webhost to enable it.


#17

BTW, ownCloud supports officially up to PHP 7.1


#18

Hey,

i think this is nothing what some one in this forums can answer as this highly depends on your access permissions to the web server environment and the possibilities you have to configure it. :confused:

This could be required, maybe the webhost can say something about the “method not allowed” or see something about it in e.g. the web server logs or configuration.