Can't sync (or upload) large files after upgrade to 10.0.3 because of .file


#1

/remote.php/dav/uploads/sgraf/2569007823/.file - server replied: Forbidden|403|0|0|||INST_NONE|

I specifically block access to .* files in my httpd server for security reasons. Why are . files now being used?


#2

Hey @stephengraf! Thanks for reporting! Which version of the client are you using? We recently found out there was a regression introduced by the performance improvements made on the exclusion list logic for 2.4. This has been fixed in:

... and is already available on 2.4.0 nightly versions.

If you're using a different client version, as long as you have the "Sync hidden files" disabled, it should indeed not try to sync your dotfiles.


#3

My client version is: Version 2.3.3 (build 8250).
I am working around by blocking only /.htaccess* and /.user*., where before I was blocking /.*.

However, it looks like owncloud is creating syncing a file called ".file" and then moving it when the error occurs.


#4

@stephengraf If the client sees the file, it will attempt to download it.