Can't update from MariaDB5 to MariaDB10

Hello,

I run an OwnCloud installation from my Synology NAS (DS920+) using MariaDB5.
I’m currently trying to update my DSM to version 7 but need to get rid of MariaDB5, due to its incompatibility with the new DSM version. Thus, I am trying to upgrade to MariaDB10.

Unfortunately, I have problems to migrate to MariaDB10 without bricking my exitsting OwnCloud installation.

When MariaDB5 is stopped, I only get an empty page, when trying to access OwnCloud. When I start MariaDB5 again, it works as expected.

Did I miss something, which I still need to reconfigure?

Steps to reproduce (aka. what I did so far)

  1. Installed MariaDB10 through the DSM package-center
  2. Exported the owncloud database from MariaDB5 using phyMyAdmin
  3. Imported the owncloud database to MariaDB10 using phyMyAdmin
  4. Created the necessary users with the necessary rights in MariaDB10 (matching the credentials of owncloud’s config files)
    5.Stopped MariaDB5 from the package center

Expected behaviour

OwnCloud should work a expected.

Actual behaviour

When stopping MariaDB5 from the package center, only a white page without any content is displayed when trying to access OwnCloud using the browser.

Server configuration

Operating system: No exactly sure, which distribution Synology is using. However, it runs on Linux.

Web server: Apache HTTP Server 2.4

Database: MariaDB5

PHP version: 7.3

ownCloud version: 10.8.0.4

Updated from an older ownCloud or fresh install: No update.

Where did you install ownCloud from: Unsure, too long ago. Probably a manual installation using the .zip from OwnCloud website.

Signing status (ownCloud 9.0 and above): gist:26c698e6d4646dacd2d0af4a21d30ab1 · GitHub
However this Signing status only works, when running MariaDB5. Stopping MariaDB5 and only running MariaDB10, I also get an empty page with no content.

The content of config/config.php:

List of activated apps:

Enabled:
  - activity:
    - Version: 2.6.1
    - Path: /volume1/web/owncloud/apps-external/activity
  - comments:
    - Version: 0.3.0
    - Path: /volume1/web/owncloud/apps/comments
  - configreport:
    - Version: 0.2.0
    - Path: /volume1/web/owncloud/apps/configreport
  - dav:
    - Version: 0.6.0
    - Path: /volume1/web/owncloud/apps/dav
  - federatedfilesharing:
    - Version: 0.5.0
    - Path: /volume1/web/owncloud/apps/federatedfilesharing
  - federation:
    - Version: 0.1.0
    - Path: /volume1/web/owncloud/apps/federation
  - files:
    - Version: 1.5.2
    - Path: /volume1/web/owncloud/apps/files
  - files_external:
    - Version: 0.8.0
    - Path: /volume1/web/owncloud/apps/files_external
  - files_mediaviewer:
    - Version: 1.0.4
    - Path: /volume1/web/owncloud/apps/files_mediaviewer
  - files_pdfviewer:
    - Version: 0.12.2
    - Path: /volume1/web/owncloud/apps-external/files_pdfviewer
  - files_sharing:
    - Version: 0.14.0
    - Path: /volume1/web/owncloud/apps/files_sharing
  - files_texteditor:
    - Version: 2.3.1
    - Path: /volume1/web/owncloud/apps-external/files_texteditor
  - files_trashbin:
    - Version: 0.9.1
    - Path: /volume1/web/owncloud/apps/files_trashbin
  - files_versions:
    - Version: 1.3.0
    - Path: /volume1/web/owncloud/apps/files_versions
  - firstrunwizard:
    - Version: 1.2.0
    - Path: /volume1/web/owncloud/apps/firstrunwizard
  - market:
    - Version: 0.6.1
    - Path: /volume1/web/owncloud/apps/market
  - notifications:
    - Version: 0.5.4
    - Path: /volume1/web/owncloud/apps/notifications
  - provisioning_api:
    - Version: 0.5.0
    - Path: /volume1/web/owncloud/apps/provisioning_api
  - systemtags:
    - Version: 0.3.0
    - Path: /volume1/web/owncloud/apps/systemtags
  - templateeditor:
    - Version: 0.4.0
    - Path: /volume1/web/owncloud/apps/templateeditor
  - updatenotification:
    - Version: 0.2.1
    - Path: /volume1/web/owncloud/apps/updatenotification
  - web:
    - Version: 3.4.1
    - Path: /volume1/web/owncloud/apps-external/web
Disabled:
  - admin_audit:
    - Path: /volume1/web/owncloud/apps/admin_audit
  - announcementcenter:
    - Path: /volume1/web/owncloud/apps/announcementcenter
  - customgroups:
    - Path: /volume1/web/owncloud/apps/customgroups
  - encryption:
    - Path: /volume1/web/owncloud/apps/encryption
  - enterprise_key:
    - Path: /volume1/web/owncloud/apps/enterprise_key
  - external:
    - Path: /volume1/web/owncloud/apps/external
  - files_antivirus:
    - Path: /volume1/web/owncloud/apps/files_antivirus
  - files_classifier:
    - Path: /volume1/web/owncloud/apps/files_classifier
  - files_external_dropbox:
    - Path: /volume1/web/owncloud/apps/files_external_dropbox
  - files_external_ftp:
    - Path: /volume1/web/owncloud/apps/files_external_ftp
  - files_ldap_home:
    - Path: /volume1/web/owncloud/apps/files_ldap_home
  - files_lifecycle:
    - Path: /volume1/web/owncloud/apps/files_lifecycle
  - firewall:
    - Path: /volume1/web/owncloud/apps/firewall
  - graphapi:
    - Path: /volume1/web/owncloud/apps/graphapi
  - guests:
    - Path: /volume1/web/owncloud/apps/guests
  - metrics:
    - Path: /volume1/web/owncloud/apps/metrics
  - oauth2:
    - Path: /volume1/web/owncloud/apps/oauth2
  - openidconnect:
    - Path: /volume1/web/owncloud/apps/openidconnect
  - password_policy:
    - Path: /volume1/web/owncloud/apps/password_policy
  - ransomware_protection:
    - Path: /volume1/web/owncloud/apps/ransomware_protection
  - sharepoint:
    - Path: /volume1/web/owncloud/apps/sharepoint
  - systemtags_management:
    - Path: /volume1/web/owncloud/apps/systemtags_management
  - theme-enterprise:
    - Path: /volume1/web/owncloud/apps/theme-enterprise
  - user_external:
    - Path: /volume1/web/owncloud/apps/user_external
  - user_ldap:
    - Path: /volume1/web/owncloud/apps/user_ldap
  - user_shibboleth:
    - Path: /volume1/web/owncloud/apps/user_shibboleth
  - windows_network_drive:
    - Path: /volume1/web/owncloud/apps/windows_network_drive
  - wopi:
    - Path: /volume1/web/owncloud/apps/wopi
  - workflow:
    - Path: /volume1/web/owncloud/apps/workflow

Are you using external storage, if yes which one: No. Running directly on NAS.

Are you using encryption: no

Are you using an external user-backend, if yes which one: no

Could you please post some lines from your owncloud.log relevant to your issue?

Sure. Every time I stop MariaDB5 (leaving only MariaDB10 running), a crash log is created. I assume this log is of most use. Due to its length in a pastebin: Crash Log - Pastebin.com

Both are running at the same time? On the same (default) port?

No, MariaDB5 is running on port 3306 and socket “/run/mysqld/mysqld.sock”, whereas MariaDB10 is running on port 3307 and socket “/run/mysqld/mysqld10.sock”. Although both are running at the same time.

What if you change the connectstring on config.php from

"dbhost": "localhost",

to

"dbhost": "localhost:3307",

I just checked that. Did change the config to

"dbhost": "localhost:3307",

and restarted the entire NAS. Unfortunately I still get an empty page, when MariaDB5 is stopped. (It works, when MariaDB5 is still running, tho) I assume OwnCloud is listening to the socket instead of the port?

With your config, ownCloud will use the port.

/**
 * Define the database server host name
 * For example `localhost`, `hostname`, `hostname.example.com`, or the IP address.
 * To specify a port use: `hostname:####`;
 * To specify a Unix socket use: `localhost:/path/to/socket`.
 */

This is not (really) surprising. For some reasons, apache/php/ownCloud are still using the “old” db-server. If you kill that process, ownCloud says good bye.

I’m not an expert on this, but I think there are some php-ini-files, that are linking your PHP with the “old” mariadb.

mysqli.default_port 3306
mysqli.default_socket /var/lib/mysql/mysql.sock