Can't zerossl or letsencrypt my Owncloud


#1

Hi everyone,
i’m proud to let you know my first owncloud personal server is online at home.
It’s a 18.04 LTS with raid 5, and works good; ssl activated.

I just wanted to get rid of the warnings about ssl in the browsers. So i decided to go for CA certification.

I’ve done all i could, but i get this when running the letsencrypt certbot i’ve just installed :

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: cloud.xxxxxxxx.mx
    Type: tls
    Detail: Fetching
    https://cloud.xxxxxxxx.mx/.well-known/acme-challenge/qjwWZ0zBRnBumI3MbiMa3oKu3DFY3siYpJwLKEPYR24:
    remote error: tls: internal error

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    you have an up-to-date TLS configuration that allows the server to
    communicate with the Certbot client.

I checked my dns : ok
I also tried the manual way with zerossl online. I could see each time my files in .well-known/acme-challenge, but same error.

Anyone ?


#2

My experience here is based on another web-app, not owncloud, but this is more a webserver- than an owncloud topic.

I don’t remember whether it was a similar fault, but the solution was easy.

I removed the .htaccess file during the initial run. Took a few seconds only, afterwards the .htaccess was moved back in place. Never had trouble since then.

HTH