Changing URL Collabora Online apps not worked

Dear All,
Today I tried to install Collabora Online 1.1.4 apps on my owncloud.

I tried to change default URL from https://localhost:9980 to my collabora server but it keep turning back to https://localhost:9980

Then I tried to override via console apps/richdocuments/lib/appconfig.php but still shown error messages

Collabora Online: Invalid URL "".
Please ask your administrator to check the Collabora Online server setting.

What should I do ?

Thank you for your assistance,

Reza Ervani
Rumah Ilmu Indonesia


After change configuration when start docker in my collabora server (it is separate server from my owncloud server) FROM :

docker run -t -d -p -e "domain=cloud\.rumahilmu\.or\.id" --restart always --cap-add MKNOD collabora/code

[NOTE ; is my owncloud server]


docker run -t -d -p -e "domain=office\.rumahilmu\.or\.id" --restart always --cap-add MKNOD collabora/code

[NOTE : 149.x.x.x is my collabora server public ip and is host and domain of my collabora server]

Owncloud CAN CONNECT INTO Collabora server.

But still have a problem :

Collabora Online: SSL certificate is not installed.
Please ask your administrator to add ca-chain.cert.pem to the ca-bundle.crt, for example "cat /etc/loolwsd/ca-chain.cert.pem >> /resources/config/ca-bundle.crt" . The exact error message was: cURL error 60: SSL certificate problem: self signed certificate in certificate chain

I've tried to copy cert.pem, fullchain.pem, and chain.pem from Collabora Server into Owncloud Server like tutorial here :

But still not working.

Any Idea ?

Thank you,
Reza Ervani
Rumah Ilmu Indonesia

Please create a new thread for this new issue (for the reasons explained in and use a valid certificate.