Client sees different certificate than browsers

help

#1

Expected behaviour

Connect to server

Actual behaviour

Fails with untrusted certificate - although all my browsers have no problem accessing the webUI

Steps to reproduce

  1. Install ownCloud Server on Apache2 HTTPD with Let’s Encrypt SSL-enabled Nginx reverse-proxy
  2. Install Windows Desktop Client
  3. Enter URL of server in the client

Server configuration

Operating system: Debian 9.4

Web server: Apache2 HTTPD with Nginx as reverse-proxy

Database: MariaDB

PHP version: 7.0

ownCloud version: 10.0.8

Storage backend (external storage):

Client configuration

Client version: 2.4.2

Operating system: Windows 10

OS language: fr

Qt version used by client package (Linux only, see also Settings dialog): /

Client package (From ownCloud or distro) (Linux only): /

Installation path of client: Program Files I guess… left it to default…

Logs

  1. Client logfile: https://gist.github.com/MrPOC/ba7e4405d10fc84b579e3c30ddc71e87

  2. Web server error log: https://gist.github.com/MrPOC/54451402a8407c9ab6fb2a4ece897e2a

  3. Server logfile: ownCloud log (data/owncloud.log): Can’t post it here, will post comment with link


#2

Server logfile: https://gist.github.com/MrPOC/c4ee72c8a685c5f7245e1866689d303c


#3

Hey,

i have checked the “www.yourdomain.be” (from the owncloud_client_log-2018-07-23-17h-06, don’t want to post your URL in public here) with https://www.ssllabs.com/ssltest/ and it seems the SSL/TLS setup is quite broken:

  1. Self signed certificate
  2. No common names
  3. No alternative names

Maybe this is the reason why the client doesn’t want to make a connection to the remote server?


#5

Okay it seems it’s a problem with the www subdomain, wtf… I’m gonna check my nginx config