Connection Timed out when moving 320,000 off files (20gb)

Hi All,

Details as per template are below but essentially I am trying to move a tree from one shared folder to another… The tree contains around 320k files totalling around 20gb of data. There is plenty of free disk space on the server which is on a local 1gb link. Server is a VM but neither the hypervisor (xcp-ng) nor the VM seem to be low on resources. Memory usage is maxed out but that seems to be normal, processor is hardly registering, IO is no where near max.

I’ve tried removing all other synced Directories and re-syncing the two shared dirs that I’m trying to move things from / too.

Expected behaviour

Move a tree from one directory to another within the owncloud tree using windows explorer.
Directories and files should be moved / re-synced in the new location

Actual behaviour

Win Explorer moves tree.
Sync client indexes files that have moved and builds a list of files to be synced.
Sync appears to start but stalls on file 0 of 320382 for some time
Sync client fails with Connection Timed out

Steps to reproduce

As for expected behaviour

Server configuration

Operating system: Ubuntu 20.04
Web server: Apache 2
Database: Maria 10.5.13
PHP version: 7.4.3
ownCloud version: 10.8.0
Storage backend (external storage): VM local disks

Client configuration

Client version: 2.9.2
Operating system: Win 10 Ent
OS language: English British
Installation path of client: C:\Program Files (x86)\ownCloud

The server in question had 8gb of RAM. I shutdown, increased to 16 and tried again. The operation still fails but I did notice the memory usage gradually creep up over time. Left overnight it is now using all 16 gb.

Not sure if that is relevant or not but I thought I would mention it.