Curl error 35 after fresh install of owncloud 9.1.5 (solved)

9.1.x

#1

Hi!

I did a fresh install of 9.1.5 on a centos 7.6 system.

My install is working fine with files, ldap sync, etc.

However, I can’t access the app store. It shows up as blank. When I look through the logs, I see the the dreaded curl error 35 which implies some sort of certificate error.

My curl version is 7.29.0

I can go to curl https://marketplace.owncloud.com and fetch the page just fine so it looks like my curl command is properly evaluating the certificate.

Is there a way to find out what url is choking the app store loading so I can debug the certificate?

Is there an update for some sort of system libs to fix this?

Thanks,

Bobby


#2

oC 9.x is OOL, please update to 10.


#3

Hi!

I’d love to update to 10 but with Centos 7, its really really messy and breaks lots of stuff. I’m going to move to 10 when the next rev of Centos comes out with updated PHP.

So, how to find/fix the curl errors?

Thanks,

Bobby


#4

Hi!

Fixed the problem via owncloud/config.php

Under trusted_domains setting, I added the local hostname for my www server. My certificate is for the www alias and my guess is that my owncloud server is trying to connect to the local hostname.

Bobby


#5

Hey,

if you can’t upgrade to 10.0.10 yet then i think it would be recommended to use at least the latest available version 9.1.8 of ownCloud 9.1.

I’m also not sure if ownCloud 9.1 is generally able to connect to the marketplace, from what i know only ownCloud 10.0+ is using it.


#6

Hi!

Will do! I’m suffering from centos/owncloud admin fatigue at the moment but will upgrade to 9.1.8 probably after Christmas. (I’m assuming CentOS will produce newer packages?)

Thanks,

Bobby