Date and Time format issue with Calendar app


#1

Version 9.1.6.11 - latest available from the repository for Raspbian on Raspberry Pi 3.
This was a fresh install.
Calendar app is 1.41 "approved"
To install the calendar app it was necessary to disable signature checking with:
'integrity_check_disabled' => true in config.php

DB is Sqlite 3, web server is apache2, PHP is 5 (5.6.3)

The issue relates to the calendar app.

Calendar clients Rainlendar and eMClient work as expected for UK - that is date/time format DD.MM.YYYY and 24h clock.

However, when viewing the calendar through the server web page the date/time format is MM.DD.YYYY and 12h clock.

The Raspberry Pi is configured with Europe:UK locale.

I can find no way to set locale for this version of OwnCloud.

Any assistance resolving this would be appreciated as searches of this and the previous forum have not so far presented a solution.

Thank you.


#2

The language setting on your personal page is British English as well?


#3

Thank you very much, tflidd. On my personal page the language was set to English. On scrolling down the language list below the separator bar I found English (British). Selecting that has fixed the issue. Locale and language are not really the same thing, but the problem is fixed - that's the main thing.
I appreciate your help. How I wish all issues could be so easily resolved!
Thanks again,
Peter