DDNS with port, with website do not work


#1

I need put only port 4433 to access my owncloud, how i put a line to work ??

Line Code WITH: RewriteRule . h.t.t.p.s://192.168.0.150/owncloud/%{REQUEST_URI} [L]

in navegate: m ysite.dns.com:4433 - the apache go to 192.168.0.150/owncloud

WHEN

Line Code WITH: RewriteRule . h.t.t.p.s://mysite.dns.com:4433/%{REQUEST_URI} [L]

in navegate: m ysite.dns.com:4433 - do not WORK

MY code in 000-default.conf
indent preformatted text by 4 spaces
<VirtualHost *:4433>
ServerAdmin webmaster@localhost
DocumentRoot /var/www/html/owncloud

<Directory />
    Deny from all
</Directory>
<Directory /var/www/html/owncloud>
    Options +FollowSymLinks
    AllowOverride None
    Allow from all
</Directory>
ErrorLog ${APACHE_LOG_DIR}/error.log
LogLevel warn
CustomLog ${APACHE_LOG_DIR}/access.log combined
ServerAdmin webmaster@localhost DocumentRoot /var/www/html/owncloud Deny from all
#********* BEGIN *********#
Alias /owncloud /var/www/html/owncloud
<Directory /var/www/html/owncloud>
    Options +FollowSymLinks
    AllowOverride None
    Allow from all
</Directory>
#***********************************#

ErrorLog /var/log/apache2/error.log
LogLevel warn
CustomLog /var/log/apache2/access.log combined
SSLEngine on
RewriteEngine on
        RewriteCond %{HTTPS} !^on$ [NC]
        RewriteRule . https://mysite.dns.com:4433/%{REQUEST_URI} [L]
    </LocationMatch>
    <LocationMatch />
        RewriteEngine on
        RewriteCond %{HTTPS} !^on$ [NC]
        RewriteRule . https://mysite.dns.com:4433/%{REQUEST_URI} [L]
    </LocationMatch>
</IfModule>
Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains" Header set X-XSS-Protection "1; mode=block" `Preformatted text`

#2

This post was flagged by the community and is temporarily hidden.