Debian 10 BADSIG apt error

running owncloud 10.7.0 on Debian 10
Signature is invalid when trying apt update

Yes, this has been reported a year ago but it seems to have returned when 10.8 was released.

GPG Error (Ubuntu 18.04 / 16.04 / …)

1 Like

Thanks @mtissington for reporting!
Yes, unfortunately, the error kept returning. Something is seriously broken in our internal OBS instance.
The good news is: We do not actually need to hide things in an internal OBS.

I’ve now moved the repo to the public openSUSE Build Service:

Please check that out, and let me know if that fixes the issue.
Note, that with this move, not only the repo url changes, but also the signing keys, as they are generated by the OBS instance.


It worked for me! I used the instructions to upgrade two ownCloud 10.7 instances (one on Debian 9 and one on Debian 10) to ownCloud 10.8, deleting the old .list files and gpg keys while I was at it.

1 Like

Worked great thanks!

Thanks for the advice, @jnweiger.
Since the link includes the version number 10.8, I am wondering whether this will still work with future versions > 10.8? Or is there a generic/non-version-specific link, we should use?

I am going to bump this from @Ascendor to @jnweiger : Is this going to make us change the key and the url every time the minor version is changed?

So if I do this now, I will be on 10.8. When 10.9 comes out, will I have to do it again?

Edit: I was attempting to upgrade from 10.5 to 10.8 via this repo. It didn’t even detect that I had anything installed that needed upgrading. Is this normal? I probably missed a step up from 10.5 to 10.6 or 10.7.

Edit 2: This was on Ubuntu 20.04.

Same here.
Ubuntu 20.04 with Owncloud 10.5

@ nblomquist EDIT 1:
I think that’s because the repro has changed (10.5 owncloud; 10.8 opensuse)

I tried to install 10.8 via apt install owncloud-complete-files but I get the following error (same when I manually download 10.8 from owncloud repo and use dpkg -i package.deb):

Die folgenden NEUEN Pakete werden installiert:
0 aktualisiert, 1 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen 32,2 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 228 MB Plattenplatz zusätzlich benutzt.
Holen:1 owncloud-complete-files 10.8.0-1+2.1 [32,2 MB]
Es wurden 32,2 MB in 5 s geholt (5.968 kB/s).
(Lese Datenbank … 284137 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von …/owncloud-complete-files_10.8.0-1+2.1_all.deb

Entpacken von owncloud-complete-files (10.8.0-1+2.1) …
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/owncloud-comple
te-files_10.8.0-1+2.1_all.deb (–unpack):
Versuch, »/var/www/owncloud/.htaccess« zu überschreiben, welches auch in Paket
owncloud-files 10.5.0-1+2.1 ist
dpkg-deb: Fehler: »einfügen«-Unterprozess wurde durch Signal (Datenübergabe unte
rbrochen (broken pipe)) getötet
Fehler traten auf beim Bearbeiten von:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Looks like a new installation attempt instead of an update. But since there are already the same file(names) from 10.5 the installation is canceled.

More or less by URL hacking I found out, that this seems to be the link for all updates of owncloud 10, not restricted to 10.8: Install package isv:ownCloud:server:10 / owncloud-complete-files

Found here: openSUSE Software
Also interesting: They are all listed as experimental here.

Could you elaborate, @jnweiger?

Same issue here…

W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: Release: The following signatures were invalid: DDA2C105C4B73A6649AD2BBD47AE7F72479BC94B

1 Like

Yes, I had set up three different repositories with the same 10.8.0 release.
While it may be a bit confusing, to see the same thing in different location, and be sure it is really the same thing, I hope there is some good use for that setup in the long run.
The URLs are almost identical, they only differ in how many digits they specify of the version number.

Forward looking statements like the above are always hard to do, without making promises.

The latter two repos technically allow for unattended automatic online updates. Please be very careful with that on your production systems.

Consider these examples:
On a small family or personal installation, I am more likely to run with all automatic updates that I can get, (because I am a tester, somewhat adventurous, can jump if something breaks, and can accept some downtime). On a bigger installations (or when I am not able to jump, when things go wrong), I probably don’t want to have unattended updates.


Thank you for clarification.
Could you also explain, why the repositories are listed as “experimental” on OpenSuse?

That is a good question. Seeing all the ‘Experimental’ badges there came as a surprise to me.

Also it says “Expert Download” where we have the perfectly normal way to obtain the packages.

I believe there is very little control, we have on the way the web interface presents things. If there is a way for me to explicitly declare that as “Not experimental” – I’d be happy to do so. It is currently definitly mislabeled.


Thanks so much for your work and the quick replies.

1 Like

I have the same issue on Ubuntu 20.04 LTS.

Ign:3 Ubuntu_20.04 | InRelease
Get:7 Release [976 B]
Get:8 Release.gpg [481 B]
Err:8 Release.gpg
The following signatures were invalid: DDA2C105C4B73A6649AD2BBD47AE7F72479BC94B
Fetched 347 kB in 2s (188 kB/s)
Reading package lists… Done
Building dependency tree
Reading state information… Done
All packages are up to date.
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: Release: The following signatures were invalid: DDA2C105C4B73A6649AD2BBD47AE7F72479BC94B
W: Failed to fetch The following signatures were invalid: DDA2C105C4B73A6649AD2BBD47AE7F72479BC94B
W: Some index files failed to download. They have been ignored, or old ones used instead.

Hey @esackbauer,

i think a solution was already given a few posts above in this topic at Debian 10 BADSIG apt error - #2 by jnweiger

Yes, I was not aware that ownCloud switched away from their own domain to opensuse.
Its working now.

1 Like

It is still a bit hard to understand for me: When I want to download owncloud for my Debian, why do I need to download from OpenSuse and not from the official owncloud server? It sounds like a workaround for me. Why should I trust a repository that is not the official owncloud repository and not even owned by my Debian distro?

1 Like

This worked for me (I’m not resonsible for your data and configurations; always make a backup!):

After removing the broken repository ( and adding the opensuse repository I still wasn’t able to update my owncloud from 10.5 to 10.8.
Apt upgrade didn’t show me a newer version. Trying to install via apt install owncloud-complete-files was aborted because there were already the same files from my 10.5 installation of the old repository (See my last post). Maybe the package name was different than owncloud-complete-files back on my initial installation in 2015.
The solution is this command which forces to overwrite the files:

sudo service apache2 stop
sudo apt-get -o Dpkg::Options::="--force-overwrite" install owncloud-complete-files
sudo service apache2 start

I was worried that this might overwrite my configuration (files, not db) so I cloned my system into a virtual machine and testet there. Everything seems to be ok. Owncloud needed the usual upgrade before the first login. Now I’m on 10.8 and never versions hopefully upgrade now using apt

1 Like

Yes, but who cares? We cannot expect that ownCloud maintains a repo for every Linux distribution. AFAIK, the desktop stuff was at OpenSuse from the beginning, thus it makes maybe sense to put everything there.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.