Decrypt-all but password recovery key not found

decrypt-all but password recovery key not found

Steps to reproduce

  1. enable encryption
  2. init recovery key with password
  3. create user
  4. upload data
  5. change password of user
  6. lost old password user
  7. decrypt-all with revovery key

Expected behaviour

decrypt all

Actual behaviour

Could not decrypt private key, maybe you entered the wrong password?
Module "Default encryption module" does not support the functionality to decrypt all files again or the initialization of the module failed!
Server side encryption remains enabled

But no password is correct

Server configuration

Operating system: RedHat 7.2

Web server: Apache 2.4

Database: MySQL 5.6

PHP version: 5.4

ownCloud version:

Updated from an older ownCloud or fresh install:
Migration 7.0 -> 8.0 -> 9.1 ->

Where did you install ownCloud from:
Tar on

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
paste the results into and puth the link here.

No errors have been found.

The content of config/config.php:

"system": {
"instanceid": "oc0eab7f16b0",
"passwordsalt": "REMOVED SENSITIVE VALUE",
"trusted_domains": [
"datadirectory": "\/ELUS\/datas",
"overwrite.cli.url": "https:\/\/",
"dbtype": "mysql",
"version": "",
"dbname": "vdocloud",
"dbhost": "localhost",
"dbtableprefix": "oc_",
"installed": true,
"ldapIgnoreNamingRules": false,
"forcessl": true,
"mail_from_address": "dsi-asi",
"mail_smtpmode": "php",
"mail_domain": "",
"proxy": "",
"theme": "valdoise",
"loglevel": 2,
"maintenance": false,
"preview_libreoffice_path": "\/opt\/libreoffice\/program\/soffice",
"trashbin_retention_obligation": "auto, auto",
"singleuser": false

List of activated apps:

- activity: 2.3.2
- comments: 0.3.0
- configreport: 0.1.1
- dav: 0.2.7
- encryption: 1.3.0
- federatedfilesharing: 0.3.0
- federation: 0.1.0
- files: 1.5.1
- files_external: 0.6.0
- files_pdfviewer: 0.8.1
- files_sharing: 0.10.0
- files_texteditor: 2.1
- files_trashbin: 0.9.0
- files_videoplayer: 0.9.8
- gallery: 15.0.0
- notifications: 0.3.0
- provisioning_api: 0.5.0
- systemtags: 0.3.0
- templateeditor: 0.1
- updatenotification: 0.2.1
- user_external: 0.4
- user_ldap: 0.9.0
- external
- files_antivirus
- files_versions
- firstrunwizard

Are you using external storage, if yes which one: local/cifs

Are you using encryption: yes

Are you using an external user-backend, if yes which one: ActiveDirectory

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';

Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration

Browser: Chrome

Operating system: Windows 10


Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...


can you test if upgrading to 10.0.4 would solve your issue?

recently there were a similar case you might look in to:

when i try to install version 10.0.4 i have other problem

root@fredcos data]# cat owncloud.log
{"reqId":"WmicV1q0G@aqkWCmWr4mKwAAAAE","level":3,"time":"2018-01-24T14:46:47+00:00","remoteAddr":"::1","user":"--","app":"PHP","method":"GET","url":"\/owncloud\/index.php","message":"touch(): Utime failed: Permission denied at \/var\/www\/html\/owncloud\/lib\/private\/Config.php#249"}
{"reqId":"WmicV1q0G@aqkWCmWr4mKwAAAAE","level":3,"time":"2018-01-24T14:46:47+00:00","remoteAddr":"::1","user":"--","app":"PHP","method":"GET","url":"\/owncloud\/index.php","message":"fopen(\/var\/www\/html\/owncloud\/config\/config.php): failed to open stream: Permission denied at \/var\/www\/html\/owncloud\/lib\/private\/Config.php#250"}
{"reqId":"WmicV1q0G@aqkWCmWr4mKwAAAAE","level":3,"time":"2018-01-24T14:46:47+00:00","remoteAddr":"::1","user":"--","app":"PHP","method":"GET","url":"\/owncloud\/index.php","message":"chmod(): Permission denied at \/var\/www\/html\/owncloud\/lib\/private\/Config.php#253"}
[root@fredcos data]# ls -al ../config/
total 56
drwxrwxr-x. 2 apache apache 107 24 janv. 15:46 .
drwxr-xr-x. 14 root apache 4096 24 janv. 15:41 ..
-rwxrwxrwx. 1 apache apache 0 24 janv. 14:55 config.php
lrwxrwxrwx. 1 apache apache 10 24 janv. 15:46 Config.php -> config.php
-rwxrwxr-x. 1 apache apache 45796 5 déc. 17:14 config.sample.php
-rwxrwxr-x. 1 apache apache 105 5 déc. 21:06 disable-updatechecker.config.php
[root@fredcos data]#

can you try this:

chown -R apache:apache /var/www/html/owncloud

and try to upgrade again?