Deleting a particular file/folder is impossible

Steps to reproduce

Expected behaviour

Tell us what should happen

Actual behaviour

Tell us what happens instead

Server configuration

Operating system:

Web server:


PHP version:

ownCloud version: (see ownCloud admin page)

Updated from an older ownCloud or fresh install:

Where did you install ownCloud from:

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
paste the results into and puth the link here.

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.


If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/…

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';

Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration


Operating system:


Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...


I’m sorry but I’m not sure I understand at all your problem, could you be a bit more chatty if you still need help.

1 Like

Thank you for responding!! I keep getting a message that a file in a specific folder cannot sync. So I tried to delete the file. I get an error message aying an error occurred. Then I tried to delete the folder the file was in. (I copied and pasted the folder to my desktop from my local machine. Then I tried to delete the whole folder that the problem folder/file is in. All keep giving the same message Error!. Server replied 503 service unavailable.
Client Docs/1 - Past Clients/Anderson Jeremy/2014/Bank_AndersonJer_2014-03-24.pdf

There is another issue I am not sure is related. In the past I had moved some folders to reorganize the directory that I have syncing. The cloud or online version of owncloud did not move these files. So they still exist on the server version (is that the online version) but they should not as the files within them are now duplicated.

You’re welcome, could you increase the verbosity of the log and check it again ?

1 Like

I don’t know exactly what you mean but I checked the link you supplied. I did discover the log files which outline the Fatal error (Webdav) as well as the Error (PHP). I copied the fatal error here:

As you can tell I am not exactly familiar with all the language, so it takes a bit to learn. I hope to solve this problem, after today I will be away for a few days, back on Monday. Thanks again.

I don’t have time at the moment, but looking through the thread, I understand this info a little better now. Should I edit the post regarding the error with all the logs and data? Drop into these locations?

You can post here the log about the fatal error, try to anonymize it if necessary.
No worries, people will try to help you if possible :slight_smile: