Desktop Client - Connection Closed

hosting

#21

I think the problem may possibly be the SSL configuration on the server so I tried to use the following command:
--httpproxy http://[user@pass:]:

But cannot get it to work.

Is there anyone out there that can help...?


#22

I've since installed OwnCloud on a new domain entirely and still getting the same issue.

Is anyone available to help...?


#23

Last entry in the log file:

{"reqId":"WnL30Ems-0ip1mWbwSrvDgAAARM","level":3,"time":"2018-02-01T11:19:45+00:00","remoteAddr":"108.162.229.161","user":"Administrator","app":"PHP","method":"GET","url":"\/index.php\/settings\/admin?sectionid=general","message":"opendir(\/home4\/wnworg\/public_html\/themes): failed to open dir: No such file or directory at \/home4\/wnworg\/public_html\/apps\/templateeditor\/lib\/mailtemplate.php#155"}

The IP address was in the trusted domains also.


#24

Ive been waiting for a thousand days for a answer on this issue and looks like no gives a shit in this .. someone answer this i have the same problem


#25

I think you need to understand that there can't be an answer or solution for every problem out there if the reason for the problem is unknown. :confused:

But maybe you can work together with @WhatNoWebsite to find something in common in your environments and to find out the reason why you're seeing this issue. Pinpointing to something in common between both environments could help you to get an answer.


#26

Does the owncloud support don't have solution about this issue? this only happens to after my version upgrade. sad to say i don't have backups.


#27

Do you guys have the older setup-owncloud.php file?


#28

I'm not sure if the ownCloud support is watching / monitoring this forums.


#29

Hi,

we have the ownCloud Admin manual:

https://doc.owncloud.com/server/10.0/admin_manual/

specifically the Installations Guide:

https://doc.owncloud.com/server/10.0/admin_manual/installation/source_installation.html

If you follow those steps and still can't get ownCloud working - feel free to ask in this forum.

ownCloud can't guarantee the functionality if you choose a server hoster and he has some specific settings that prevent ownCloud from working properly. This could be firewall settings, or older php installations.

ownCloud support is actually responsible for the enterprise customers. That's what they buy if they pay for ownCloud - the support.

This forum is thought as a user-to-user help forum. Where experienced users can help the new ones


#30

@WhatNoWebsite : is there any update on this topic, it jzst looks like is still open. Have you managed to resolve this? I have the same problem with one of the windows clients … connection closed and operation interrupted.

Any related information is appreciated, thank you.


#31

Nah, no update. Perhaps in the new year…?


#32

Maybe this might help you … Many "operation canceled"/"connection closed" errors during sync


#33

Thats a great info. I didn’t know that there are such different, you learn something every day. :slight_smile:

I did a short search for this “mpm” keyword in the documentation:

https://doc.owncloud.org/server/latest/admin_manual/search.html?q=mpm

and it seems the mpm could make a difference:

https://doc.owncloud.org/server/latest/admin_manual/installation/source_installation.html?highlight=mpm#multi-processing-module-mpm


#34

@tom42 @WhatNoWebsite i am testing out the latest version of the client , since i am really more convinced that is a client issue. if you connect via browser, all is well with the world. So far no real progress… just more of the same error. (QNetworkReply::NetworkError(RemoteHostClosedError)) Some Data gets downloded, some does not.

Can someone explain (or post an informative link) what are the Conditions the Owncloud server might close the connection? much apreciated :slight_smile:

Cheers!


#35

Hi Natty,
have you solved this issue ? I have exactly the same problem. A fresh install of Owncloud 10.0.8 on a Centos 7, PHP 7 and Apache 2.4. I follow the documentation, no warning in the admin page, everything is working through the Web interface. But still Connection closed with the client.
I’ve tried MPM settings, KeepAlive Settings, nothing is working.
Thanks


#36

@christianlx : i tried several things … (from https://doc.owncloud.org/server/latest/admin_manual/issues/general_troubleshooting.html)
I also increased this values in php.ini:

  • post_max_size to 16G
  • upload_max_size to 16G
  • max_file_uploads to 200

this helped with the performance … but i found out that over night the files were all sync-ed (even with the tons of errors )…so in my case, the connection is just so slow from outside the network. If i connect from the same vlan, it works. Also using the browser form outside the network seems fine… its just the client that has this problem.
I also created an enviornment variable for chunking (can not remember the source for this action …)
Name: OWNCLOUD_CHUNKING_NG
Value: 0

I also installed the 2.5 version of the client, i got more detailes of this error with this version.
Still running tests …


#37

I spent my afternoon on this but I finally found. As I though that it was really a server side issue, I start from a default owncloud config.php. It was working without the APCU cache. As I couldn’t let this server without it I start to search and finally found issue with this module like here : https://github.com/krakjoe/apcu/issues/172
The solution for me was to comment the apc.serializer in /etc/php.d/apcu.ini
I’m not a developper so I don’t know if there is a side effect to this but for me the connection closed problem is resolved with this. Hope it helps.


#38

@christianlx Thanks for sharing, i’ll try this next. Cheers!


#39

Hey, this is a really great observation. Maybe it could be possible that you share this information with the ownCloud development team so a warning could be built into ownCloud?


#40

Hey all,

concerning the different MPMs i just got an upgrade to Debian 9.5 on my server and found the following changes in the Apache documentation:

apache2 (2.4.25-3+deb9u5) stretch; urgency=medium

  • This package upgrades mod_http2 to the version from apache2 2.4.33. This
    fixes a lot of bugs and some security issues, but it also removes the
    support for using HTTP/2 when running with mpm_prefork. HTTP/2 support
    is only provided when running with mpm_event or mpm_worker.

Maybe there is a reason why HTTP/2 can’t be used together with mpm_prefork. Could it be possible that this had caused some of the seen issues here?