Docker run LDAP problem

Hello everyone!

I am trying to run on ubuntu service OCIS using docker using the standard instruction (Container Setup) . But when I am running docker from “Recurring Start of Infinite Scale” it fails. I tried to find the solution, but failed. What can I do?

It is written the following:

docker run
–name ocis_runtime
-p 9200:9200
–mount type=bind,source=$PWD/ocis/ocis-config,target=/etc/ocis
–mount type=bind,source=$PWD/ocis/ocis-data,target=/var/lib/ocis
-e OCIS_URL=https://
{“level”:“error”,“service”:“graph”,“error”:“LDAP Result Code 200 "Network Error": dial tcp connect: connection refused”,“time”:“2023-03-12T17:39:48.910140716Z”,“message”:“could not get ldap Connection”}
{“level”:“error”,“service”:“graph”,“error”:“LDAP Result Code 200 "Network Error": dial tcp connect: connection refused”,“time”:“2023-03-12T17:39:48.910169712Z”,“message”:“autoconnect could not get ldap Connection”}


it seems like your docker container cannot access the configured LDAP server.
Remember docker containers have their own network separate from the host.

If you would exec into the container, you’d need to be able to connect to the LDAP server using a valid IP address or DNS entry.

connection refused

This usually indicates a firewall problem to me, but it could also be something else because it is docker.


I don’t have LDAP server and never used it. It is just happening when I follow the standard instruction and run the container.

I tried to install on fresh Ubuntu 22.04 in the cloud.