E-Mail Address problem


#1

Hallo,
my Admin page shows the following log entry:
"Exception: {"Message":"Address in mailbox given [xxx@yyy.de] does not comply with RFC 2822, 3.6.2.","Exception":"Swift_RfcComplianceException","Code":0,"Trace":"#0 \/var\/www\/cloud\/3rdparty\/swiftmailer\/swiftmailer\/lib\/classes\/Swift\/Mime\/Headers\/MailboxHeader.php(263): Swift_Mime_Headers_MailboxHeader->_assertValidAddress('xxx@..')\n#1 ...."

In this error, the e-mail-address (xxx@yyy.de) is indeed wrong. But I can't find where it is defined. In the user-section,the address is correct.
I haven't installed a mail server program (Swiftmail).

The mail address for notifiation set up in admin, is a different one.
Where must I look for thuis wrong address?


#2

A user's mail is shown on the user's personal page and in the user overview of the admin. There might be other apps sending mails but we can't know what you have installed (e.g. the webmail app).


#3

Thanks
at the two places you indicated, the e-mail is given in a correct form (with a dot between name and surname, whereas the error message indicates a comma between them).
I have tried to locate the wrong version using grep -r 'string' from \ as administrator, but to no avail.

You asked for installed apps. The error message indicates swiftmail, which I did not install and which is not listed under Apps. But the directory certainly is there (is it pre-installed?)

I also tried to find the string in that directory, but also to no avail.
Any further leads?
Yours


#4

It looks like some script in swiftmailer composes addresses wrongly from the data given in the owncloud accounts.
Which one would that be?
Any idea?


#5

Swiftmailer is just a library used for that purpose. It's probably the best to report this to the bugtracker for further investigation: https://github.com/owncloud/core/issues


#6

@akoerber can you produce your full owncloud.log? That should give us the full exception to use for debugging your issue. It looks like there is an incorrect mail address stored somewhere - perhaps in the database. Let's first see the exception trace from your owncloud.log file.


#7

Thanks, the error is still /again here: