Error after changing data

external_storage
help

#1

Hi guys

New to Linux etc and have done well up till now. I have changed the config.php file to store data to /media/harry/My Book/Owncloud

but I'm hitting this error now -

Data directory (/media/harry/My Book/Owncloud) is invalid

Please check that the data directory contains a file ".ocdata" in its root.

Any help?

Reason for changing directory is, I'm hosting Ubuntu on virtualBox to decide if I like it or not, and have set the HDD at 4gb, which isn't enough to upload my pics, I have a 1tb external drive that I wish to use for the storage instead?

Thanks


#2

Can you access this folder with webserver permissions? Ubuntu/Debian:
sudo -u www-data ls -lisa /media/harry/My Book/Owncloud
is there a .ocdata?


#3

Hi no there is no
.acdata file. But there wasn't one in the primal folder with and that worked.

Every time I give permission or change owner it seems to revert back. Is this because it's a formatted for windows?


#4

Please be aware that moving the datadir is currently not supported:

so its the best to start from scratch and directly choose the external disc as a datadir during the setup.

The issue itself is most likely caused by the NTFS fileformat and wrong permissions on that. On such discs you need to choose correct permissions during the mount of it. The linux command:

man mount

or some tutorials about mounting NTFS discs should lead you to the info how to mount that device correctly with the user of your webserver as the owner.


#5

ah ok, I wasn't aware it wasn't support, thought it was simply a case of changing the config.php file


#6

Tried what you said and I get "ls cant access /media etc Permission Denied


#7

So this is a starting point where the infos posted above will support you with that task to give your webservers user the correct permissions to access this external device.