Error in Updater | 9.1.2 to 9.1.4


#1

Hello. I run OwnCloud on a shared hosting server. Version is 9.1.2. I tried to update to version 9.1.4 via the updater. But it generates the following error message:

Client error response [url] http://localhost/index.php/occ/config:list [status code] 404 [reason phrase] Not Found

Do you have any ideas how to solve the problem?

Kind regards, Maik

Server configuration
Operating system: ??
Web server: ??
Database: MySQL
PHP version: 7.0 CGI
ownCloud version (see ownCloud admin page): 9.1.2

Integrity status for oC9+

Technical information
=====================
The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix
them.
Results
=======
- files_external
	- FILE_MISSING
		- 3rdparty/aws-sdk-php/Symfony/Component/ClassLoader/Tests/Fixtures/Apc/alpha/Apc/NamespaceCollision/A/Bar.php
		- 3rdparty/aws-sdk-php/Symfony/Component/ClassLoader/Tests/Fixtures/beta/NamespaceCollision/A/B/Bar.php
		- 3rdparty/aws-sdk-php/Symfony/Component/ClassLoader/Tests/Fixtures/beta/NamespaceCollision/A/B/Foo.php
Raw output
==========
Array
(
    [files_external] => Array
        (
            [FILE_MISSING] => Array
                (
                    [3rdparty/aws-sdk-php/Symfony/Component/ClassLoader/Tests/Fixtures/Apc/alpha/Apc/NamespaceCollision/A/Bar.php] => Array
                        (
                            [expected] => 17ae7563221cc6eb55ca1415b06a10a6f35b5255efcbce1d214c4dd6ae80c695f2215b9866bce2d44274607df19a1ee07ab2a65e0ccf28af3972b74c3bc4a153
                            [current] => 
                        )
                    [3rdparty/aws-sdk-php/Symfony/Component/ClassLoader/Tests/Fixtures/beta/NamespaceCollision/A/B/Bar.php] => Array
                    (
                        [expected] => e56ef054febd40702b17c15332ee07f79883f7845436f7d063db65dc90f6c757825859d3fc2ef3bc76b74ae3991efbfc09889c28f63d58c84ea0bc8ca779c340
                        [current] => 
                    )

                [3rdparty/aws-sdk-php/Symfony/Component/ClassLoader/Tests/Fixtures/beta/NamespaceCollision/A/B/Foo.php] => Array
                    (
                        [expected] => 3b92c5106fc09068943a40d4ca82c34ff3030013c85500f7cde5caf7ea02ecf1a011a07db423a255e0a0e1dd746d2fdad472b51481b905486c861a58601b3442
                        [current] => 
                    )

            )

    )
)

#2

Hi,

the updater app is not reliable and i'm always suggesting to not use it to have working updates / upgrades. So instead of using the updater just:

  1. Delete all files and folders except /data/ and /config/ from your installation directory
  2. Extract the 9.1.4 archive into the installation directory
  3. Run the upgrade routine