Error when trying to use the Guest App

I try to use the Guest App to share files and folders with Non-Owncloud users, but after placed the email address of the recipient, I get an error message “Error while sharing”.

Any idea or fix for It? The Guest App is the latest available on the market.


if i’m creating a new thread in the “Server” category i’m getting the template below presented. It seems this is currently completely missing in this “Apps” category. :confused:

Maybe you could fill out the information asked within it so people are better able to help you?

Thanks for reporting issues back to ownCloud! This is the issue tracker of ownCloud, if you have any support question please check out

This is the bug tracker for the Server component. Find other components at

For reporting potential security issues please see

To make it possible for us to help you please fill out below information carefully.

Before reporting any issues please make sure that you're using the latest available version for your major branch (e.g. 9.0.x), see
### Steps to reproduce

### Expected behaviour
Tell us what should happen

### Actual behaviour
Tell us what happens instead

### Server configuration
**Operating system**:

**Web server:**


**PHP version:**

**ownCloud version:** (see ownCloud admin page)

**Updated from an older ownCloud or fresh install:**

**Where did you install ownCloud from:**

**Signing status (ownCloud 9.0 and above):**

Login as admin user into your ownCloud and access 
paste the results into and puth the link here.

**The content of config/config.php:**

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.


If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

**List of activated apps:**

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

**Are you using external storage, if yes which one:** local/smb/sftp/...

**Are you using encryption:** yes/no

**Are you using an external user-backend, if yes which one:** LDAP/ActiveDirectory/Webdav/...

#### LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';

Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

### Client configuration

**Operating system:**

### Logs
#### Web server error log
Insert your webserver log here

#### ownCloud log (data/owncloud.log)
Insert your ownCloud log here

#### Browser log
Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

My best guess is, that your mail configuration is broken. Can your ownCloud really send e-mails? Here it works like a charm.

Hi Alfred

Thanks for Your thoughts about the issue: I was thinking the same, but I made a double check, and the email notification works fine on my OwnCloud server.

Please check owncloud.log to see where the exact issue is.

Hey, i think it still could make sense if @alberto_comper could provide all information in the template rather then just having a look in the owncloud.log.

In this case, I wouldn’t insist on the template, but an excerpt of the log would really be of interest.


I found and fixed the problem: I just had to set the sharing preferences in the administration panel as the following:


Alberto, Great to hear from your success. Which options did you change?

I have slightly fewer options checked.

1 Like

Hi Alfred, sorry for the late response. To be honest, I didn’t record the previous situation, but I’m pretty confident that “Allow user to share via link”, “Allow public download”, “Allow sharing with groups” are key preferences for this.

Hi Alberto,
Don’t worry, its OK. As long as it works… :wink: