EXTRA_FILE bug on every file > Integrity check during upgrade to 9.1.4


#1

I ran the update sequence on my OC to update to version 9.1.4.
The update appears to have worked and OC clients working fine, but the integrity check notice keeps appearing and the 'list of invalid files...' report appears to contain every single file on the OC server - see sample below.

Note: my OC is configured to use external storage of type local for all content.

Is there some way I can manually resolve these EXTRA_FILE warnings?
As far as I can tell, they are not extra files and definitely have not been deleted.

The manual suggests that the signature.json file may be relevant.

EXTRA_FILE
The file does not exist in signature.json. This usually happens when a file has been removed and signature.json has not been updated. It also happens if you have placed additional files in your ownCloud installation folder.

Sample of 'list of invalid files report'

Results
=======
- core
	- EXTRA_FILE
		- data2/sub-NNN0002_task-rest_bold.nii.gz
		- mrs_ms/Aki/People_-_Summary.txt
		- mrs_ms/labphoto.gif
... thousands more ...

Raw output
==========
Array
(
    [core] => Array
        (
            [EXTRA_FILE] => Array
                (
                    [data2/sub-NNN0002_task-rest_bold.nii.gz] => Array
                        (
                            [expected] => 
                            [current] => 6dbe0d80fddb6d28164499e009e700ab05518e3658315a651fee152b31f7cc5d9e7e6271d01b60bcf5a90ede74ca9b68e4a6ea3c8c2218086750d3f74fa36738
                        )

                    [mrs_ms/Aki/People_-_Summary.txt] => Array
                        (
                            [expected] => 
                            [current] => ad54c19573ba9506657d03aeeff1960a30a2f36eb3e9df0dc0113ec6a1337db85f818997cc03b36b20b94377ebfc864bb31d636b9a85191b48a14e83443e4401
                        )

                    [mrs_ms/labphoto.gif] => Array
                        (
                            [expected] => 
                            [current] => 5183352eb6f40a95b176681edb8b16b54080656275a92b5a972119b0c55943ff008e88a0e4993c63016cd8ffe68e0d7686bdd2b3bdd20a64985bb2fb43be020c
 ... thousands more ...

#2

Hi,

in this case "EXTRA_FILE" means those are files are there and ownCloud doesn't expect that these are there. You can't have any additional files within the installation folder of owncloud (e.g. /var/www/owncloud) besides in the /var/www/owncloud/data.

To fix this you need to research where these /data2/* and /mrs_ms/* files and folders are coming from. Most likely you have put them in there.


#3

I see. In that case let me explain my setup.

At my institution, we have a cluster of servers with chunks of storage allocated to users, and mounted by NFS onto VMs and workstations. For each user group, we mount their storage drive into the OC directory and then give OC server access to it by the external storage > local setup. So for example, the directory /var/www/ownloud/mrs_ms is treated as external storage MRS, and everything has worked fine (until trying to update).

I think you're saying that we should have mounted that folder inside /var/www/owncloud/data and the EXTRA_FILE bug would not have happened?


#4

Just to clarify: This is not a bug but a misuse of the external storage app. The complete /var/www/owncloud folder is exclusive to ownCloud and shouldn't be touched at all (besides modifications within the config/config.php file and the themes/ folder.

Mounting those local storages into the /var/www/owncloud/data would make things even worse.

A correct setup for your use case would be to mount this "mrs_ms" folder into e.g. /opt/msr_ms or /mnt/msr_ms and then include these folder into ownCloud via the external storage app.


#5

Thanks for clarifying that.

Is there a recommended way to 'migrate' an external folder without corrupting the DB?
Or should the external storage be removed and recreated at the new location?


#6

What if this Array is as voluminous as mine?
Itegrity Fail Report of odb.blausand.net
I guess i can't just kill all these files?