Extra https// in url when accessing with browser


#1

Steps to reproduce

  1. type in url to browser
  2. wait for the server to return saying it cant find the url
  3. look in the url and find an extra https//

Expected behaviour

I would expect to get to the index page of my owncloud at https://example.com

Actual behaviour

The browser returns an error saying it cant find https://https//example.com

After it fails if i remove the extra https// I get the login, and when connecting through the windows app everything works.

Server configuration

Operating system:
linux owncloud 3.13.0-92-generic #139-Ubuntu

Web server:
apache2

Database:
mysql

PHP version:
5.5.9-1ubuntu4.17

ownCloud version: (see ownCloud admin page)
9.1.0

Updated from an older ownCloud or fresh install:
fresh

Where did you install ownCloud from:
owncloud site

The content of config/config.php:

{
 "system": {
  "updatechecker": false,
  "instanceid": "ocow55fos16g",
  "salt removed"
  "secret removed"
  "trusted_domains": [
    "domain removed"
  ],
  "datadirectory": "\/var\/www\/owncloud\/data",
  "overwrite.cli.url": "https:\/\/domain removed\/owncloud",
  "dbtype": "mysql",
  "version": "9.1.0.15",
  "dbname": "oc",
  "dbhost": "localhost",
  "dbtableprefix": "oc_",
  "dbuser removed"
  "dbpassword removed"
  "logtimezone": "UTC",
  "installed": true,
  "mail_from_address removed"
  "mail_smtpmode": "smtp",
  "mail_domain removed"
  "overwritehost": "https:\/domain removed"
 }
}

List of activated apps:

Enabled:
- activity: 2.3.2
- comments: 0.3.0
- dav: 0.2.5
- federatedfilesharing: 0.3.0
- federation: 0.1.0
- files: 1.5.1
- files_antivirus: 0.9.0.0
- files_pdfviewer: 0.8.1
- files_sharing: 0.10.0
- files_texteditior: 2.1
- files_trashbin: 0.9.0
- files_versions: 1.3.0
- files_videoplayer: 0.9.8
- firestrunwizard: 1.1
- gallery: 15.0.0
- notifications: 0.3.0
- provisioning_api: 0.5.0
- systemtags: 0.3.0
- templateeditor: 0.1
- updatenotification: 0.2.1
Disabled:
- encryption
- external
- files_external
- users_external
- users_ldap

Are you using external storage, if yes which one:
no

Are you using encryption:
yes (i thought i was… but the encryption disabled from above makes me think no?)

Are you using an external user-backend, if yes which one:
no

Client configuration

Browser:
firefox quantum 62.0 64-bit

Operating system:
windows 7


#2

here should be a comma. after data"

9.1 is end of life. please consider upgrading.

please remove the https here


#3

Hi dimitry thank you for the reply

  • There is a comma after datadirectory, i typed in the configs by hand to remove the sensitive info and the ".’ is a typo.

  • i’ll look into upgrading, didnt realize my install was so old…

  • remove the https from where? is that what is causing my problem?


#4

Hey,

i think @dmitry is referring to this one:

when comparing this with the examples in the documentation / config.sample.php:

https://doc.owncloud.org/server/latest/admin_manual/configuration/server/config_sample_php_parameters.html#proxy-configurations

https://doc.owncloud.org/server/latest/admin_manual/configuration/server/reverse_proxy_configuration.html

this looks wrongly configured in your config.php


#5

Thank you so much, this seems to have fixed my issue!

Now I need to look into upgrading…