File is locked (file more than 100GB)

hosting

#1

Hello,

When I upload a file more than 100GB, I have a message "file locked" at the end of upload and my file doesn't appeared. I have no problem with a 7,8GB file.
My configuration is:
<?php
$CONFIG = array (
'instanceid' => '****************',
'passwordsalt' => '*************',
'secret' => '**************',
'trusted_domains' => array ( 0 => 'data.domain.com', ),
'datadirectory' => '/var/www/vhosts/data.domain.com/httpdocs/data',
'overwrite.cli.url' => 'http://data.domain.com',
'dbtype' => 'mysql',
'version' => '10.0.2.1',
'dbname' => '******',
'dbhost' => 'localhost',
'dbtableprefix' => 'oc_',
'dbuser' => '**********',
'dbpassword' => '***********',
'logtimezone' => 'Europe/Paris',
'installed' => true, 'integrity.check.disabled' => true,
'memcache.local' => '\OC\Memcache\APCu',
'memcache.locking' => '\OC\Memcache\Redis',
'redis' => [ 'host' => 'localhost', 'port' => 6379,
'timeout' => 0.0,
'password' => '', // Optional, if not defined no password will be used. ],
);

I try my upload after I have this option: 'filelocking.enabled' => false, And it's ok now. I think, it's not good to disable that, no ?

What can I do ?

Thanks


#2

Hello,

I have try to disable APCu without success. The only way to solve my problem is to disable lock...
Can you help me ?

Thanks


#3

Hello

Anyone can help me ?
I have try with the version 9 with sucess !
But it shloud be better use version 10 no ?

Thanks for your help