File was deleted from the server

Getting the following error that is stopping a client syncing.

It sounds like it is sayinga file has been deleted from the server (i.e. by longing into Linux and doing a rm filename) but I haven't deleted anything from the server and I am the only one with the login. I haven't even logged into Linux for about a month.

Any ideas how to sort this?


Can you please supply more information about the client and server versions?

Did you update your client?

Is this a shared folder, external storage etc?

Thank you

@funkytwig Do you have more info?

Server is Just updating to 9.1.6 (sorry, think I mean

Was there some type of way of running a command that syncs the database with the filesystem? I seem to remember coming across something like that.

This should be occ files:scan

Do you still have an answer to this @funkytwig ? This would help me track down something related. Thank you

Just a bog standard local folder. I Have now updated client to 2.3.2.

I tried turning off folder (i.e. clicking on checkbox so it was not shared), checking the folder was deleted from lcient PC and sharing again. I now have more errors.

This is starting to cause us real problems as its one of our main folders.

Just to reiterate, these file have not been deleted from the server manually. The only way we change the folders content is trough via the owncloud client.

Hi there,

we have the same iusse. One of our users told us that there are some files with the same error message. We use ownCloud 9.1.5 (stable).

In addition, the user deleted some of these files via the webinterface. The files on the server are gone but the webinterface shows deleted files (as if these files would still exist). If one tries to open these files the owncloud complains about missing files.

However, the story is really crazy since in the same folder a subfolder is displayed twice! If one opens each of those folders the content is identical. In the filesystem the folder is unique (as confirmed by the files:scan mode).

Do you have any idea how to

  1. get rid of this warning and
  2. get rid of the second folder?

Thanks for your help!

We still have not resolved this and it is obviously causing big problems. some of our users have stooped using owncloud.

Will look into raising it as a bug.


If it is in a shared folder and it was about moving files, it could maybe be which has a server side fix pending.
Although I'm not sure as you'd need to describe your setup further I think.

I was going to make a new topic, but I'll post it here instead, as this is the same issue I'm having.

I'm on a laptop currently, using the Windows client, Windows 7 x64, Owncloud client version 2.3.2 (build 6928) my friend hosts the server. It does the same when I use my desktop PC. This has persisted through a couple of updates to both my client and the server. We've tried reindexing, it didn't help. I'll ask what version his server is on when he's next around. (Edit: 10.0.1)

Issue: Whenever I try and delete or change files from in certain folder, C:\Users\Visi\ownCloud\References\Images\Food\Sweets I get "file deleted from server" errors and syncing stops. The problem is just with this one directory.

I'm aware the images were deleted, I just deleted them. On the next sync Owncloud scans, notices anything I removed or changed in this specific folder, tries to re-download it, discovers it's gone from the server and absolutely freaks out with "File Removed from Server". It never finishes syncing because it's too busy worrying over the supposed errors. The image below is the result after I just attempted to remove the whole thing, but it locks up even if I remove just one image. I can't even scroll down as the window wasn't designed to display that many error messages.

Would like a fix for this... Can supply more information if needed.

This is a different error, CSync failed to access, not saying it is not related but it is a different problem.

I think the workround is to copy everything locally. Remove the shared folder, create a new one and copy stuff back.

Or just delete the offending files from the web interface, and retrieve them from backup.


All very likely to be

We are seeing a lot of these "File was deleted from the server" as well.

version: ownCloud 9.1.5 (stable)


Repair step to cleanup the mess (needs testing): (occ maintenance:repair then occ files:scan --all)