Folders not available after update to 9.1.0

help

#1

Error message after login: "Directory not available. Please check log-file or contact system admin"

Steps to reproduce
1. manual upgrade from 8.2.7 to 9.0.5 (all files deleted, exept /config, /data, /theme, copy package unzip)
2. upgrade via webbutton failed (timeout?)
3. upgrade redone with occ, successful with errors (tables exists like oc_adressbook)

Expected behaviour
web interface appears, login possible, on click on folders: files show up

Actual behaviour
onclick on folders: not available, check log or contact administrator

Server configuration
Operating system: Debian 7.11 (Plesk)
Web server: apache/nginx
Database: MYSQL
PHP version: 5.6.26
ownCloud version (see ownCloud admin page): 9.0.5
Updated from an older ownCloud or fresh install: updated from 8.2.7
ownCloud log:
{"reqId":"","remoteAddr":"","app":"PHP","message":"require_once(\/var\/www\/vhosts\/xxx\/httpdocs\/owncloud\/apps\/files\/appinfo\/remote.php): failed to open stream: No such file or directory at \/var\/www\/vhosts\/xxx\/httpdocs\/owncloud\/remote.php#138","level":3,"time":"2016-09-28T05:08:59+00:00","method":"PROPFIND","url":"\/remote.php\/webdav\/","user":"xx"}
{"reqId":"x","remoteAddr":"x","app":"PHP","message":"require_once(): Failed opening required '\/var\/www\/vhosts\/myfilestorage.de\/httpdocs\/owncloud\/apps\/files\/appinfo\/remote.php' (include_path='\/var\/www\/vhosts\/x\/httpdocs\/owncloud\/3rdparty\/pear\/console_getopt:\/var\/www\/vhosts\/x\/httpdocs\/owncloud\/3rdparty\/pear\/pear_exception:\/var\/www\/vhosts\/x\/httpdocs\/owncloud\/3rdparty\/pear\/pear-core-minimal\/src:\/var\/www\/vhosts\/x\/httpdocs\/owncloud\/3rdparty\/pear\/archive_tar:\/var\/www\/vhosts\/x\/httpdocs\/owncloud\/3rdparty\/phpseclib\/phpseclib\/phpseclib:\/var\/www\/vhosts\/x\/httpdocs\/owncloud\/lib\/private:\/var\/www\/vhosts\/x\/httpdocs\/owncloud\/config:\/var\/www\/vhosts\/x\/httpdocs\/owncloud\/3rdparty:\/var\/www\/vhosts\/x\/httpdocs\/owncloud\/apps:.:\/opt\/plesk\/php\/5.6\/share\/pear:\/var\/www\/vhosts\/x\/httpdocs\/owncloud') at \/var\/www\/vhosts\/x\/httpdocs\/owncloud\/remote.php#138","level":3,"time":"2016-09-28T05:08:59+00:00","method":"PROPFIND","url":"\/remote.php\/webdav\/","user":"x"}

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):
server-side-encryption enabled

Integrity status for oC9+
no apps enabled/all disabled (contacts and calendar app were active on 8.2.7 before update)

Integrity checker has been disabled. Integrity cannot be verified.

What I tried:
- As I had some problems with directory permissions after copyying new package, maybe this could be the reason. I executed the script for strong directory permissions with root for http-user and rececked with scp-client: didn`t help.

  • checked path to /data in config.php: seems to be correct

  • changed php-version from 7.0.11 to 5.6.26

  • rescanned users (as mentioned in the upgrade how-to)

  • removed all additional php and apache directives (strict-transport-security, redirect permanent to https,


#2

Looks similar to:

Could you compare the output of occ config:list with the part i had posted here: https://github.com/owncloud/core/issues/26205#issuecomment-249484834


#3

"core": {
"OC_Channel": "production",
"backgroundjobs_mode": "ajax",
"default_encryption_module": "OC_DEFAULT_MODULE",
"encryption_enabled": "yes",
"global_cache_gc_lastrun": "1439732628",
"installedat": "1390565389.6941",
"lastcron": "1475041470",
"lastupdateResult": "[]",
"lastupdatedat": "1475043570",
"oc.integritycheck.checker": "{\"Application to check\":{\"EXCEPTION \":{\"class\":\"Exception\",\"message\":\"App not found\"}}}",
"public_caldav": "calendar\/share.php",
"public_calendar": "calendar\/share.php",
"public_calendarplus": "calendarplus\/share.php",
"public_calendarplusevent": "calendarplus\/shareevent.php",
"public_documents": "documents\/public.php",
"public_files": "files_sharing\/public.php",
"public_gallery": "gallery\/public.php",
"public_webdav": "files_sharing\/publicwebdav.php",
"remote_caldav": "calendar\/appinfo\/remote.php",
"remote_calendar": "calendar\/appinfo\/remote.php",
"remote_calendarplus": "calendarplus\/appinfo\/remote.php",
"remote_carddav": "contacts\/appinfo\/remote.php",
"remote_contacts": "contacts\/appinfo\/remote.php",
"remote_contactsplus": "contactsplus\/appinfo\/remote.php",
"remote_core.css": "\/core\/minimizer.php",
"remote_core.js": "\/core\/minimizer.php",
"remote_files": "files\/appinfo\/remote.php",
"remote_filesync": "files\/appinfo\/filesync.php",
"remote_mozilla_sync": "mozilla_sync\/appinfo\/remote.php",
"remote_webdav": "files\/appinfo\/remote.php",
"repairlegacystoragesdone": "yes",

some of the path looks different to the one you postet. How can I correct them?


#4

Hi,

i'm marking this as solved. Please follow the posted issue at github:


#5

Addtional comment: Make sure ALL files are deleted --> hidden files are not displayed in ssh client (like WinSCP)
upgrade to latest version solved my problem. Thx RealRancor