Forbidden error with desktop client

help
9.1.x

#1

So, Owncloud has been working flawlessly, and I have been loving it. I have been using hostripples to host owncloud, as they say that owncloud is allowed.

Onto my issue, I was using owncloud fine for about two weeks straight, and then one day when i turned my computer on, it asked for my password for my owncloud account, I thought this was odd, and just quit out of the program and reopened it. Unfortunately, the prompt for password was still there.

After making sure I was on a HTTPS connection, I entered my password. When I did this, it instantly popped back up asking for my password again. At this point I was extremely confused, and double checked my password was typed correctly, which it was.

The next thing I tried, was deleting my local account from the computer I was having issues with, then when I tried re-adding the computer, I was faced with an "access to server is forbidden by server. To verify you have proper access click here to access the service with your browser."

Literally the day before, I was using owncloud fine, and I changed no settings in between that time. I hadn't changed anything in a week or more actually.

So assuming my webhost (hostripples) had changed a security setting I wrote them. They informed me that the issue is something within owncloud, however I feel they changed something to stop me from using owncloud for cloud storage for whatever reason.

I have verified this on multiple computers, running windows 8.1, windows 10, and Mac OS.

I have tried disabling mod_security, and still am faced with this issue. I don't know even how I could troubleshoot this considering the fact that I didn't change anything.

To narrow down any issues, I completely wiped my owncloud install and started from scratch just now, much to my surprise, it still is giving me the same error.

I am so frustrated at this point and any suggestions would be great. I made a test account for anyone that would like to try a desktop client of their choice, but I am sure you will find the same results.

https://darkstorm-cloud.com/owncloud

user: testaccount
password: testaccount

Thank you in advance for any help!!

Steps to reproduce
1. Log into desktop client (windows or Mac)
2. Enter username + password
3. Red message saying access forbidden by server, cannot use desktop client at all.

Expected behaviour
Sync client works fine and can be logged into

Actual behaviour
Access is forbidden by server

Client configuration
Client version: ownCloud-2.2.4.6408
Client operating system: Windows 10 Home 64-Bit

Server configuration
Operating system: See http://darkstorm-cloud.com/info.php
Web server: See http://darkstorm-cloud.com/info.php
Database: MySQL
PHP version: 5.6.29
ownCloud version (see ownCloud admin page): ownCloud 9.1.3 (stable)
Updated from an older ownCloud or fresh install: Completely clean install
Special configurations (external storage, external authentication, reverse proxy, server-side-encryption): Shared server

ownCloud log (data/owncloud.log)
Contains nothing important as I just did a clean install.


#2

Yes, sounds like a change on the server side. Would recommend to try a simple webDav client like Cyberduck. Maybe WebDAV connections were disallowed or they have changed or newly implemented CDN with WEBDAV switched off, we had that one before ...


#3

Hmm, looks like you're onto something here, I will contact my host and let you know what they say.


#4

Correct me if im wrong, but did they completely ignore what you said?


#5

Further update here, my host says they allow web disk (I guess thats the same as WebDAV?)

it is currently enabled too.

This is getting more and more confusing the deeper into this i get.


#6

Sounds like the same, yes. As the error is with Cyberduck as well and you didn't change stuff something must have happened. For details a litmus test might help, if you can run it, or your hoster can run it: http://sabre.io/dav/litmus/


#7

I apologize for my lack of knowledge with webservers, they are something that I mostly stumble around and typically just figure things out.

I installed sabreDAV at https://darkstorm-cloud.com/SabreDAV but when I go to https://darkstorm-cloud.com/SabreDAV/vendor/autoload.php the page is blank and nothing happens, am I doing something wrong, or is this the expected outcome if WebDAV is blocked?

Thanks again for trying to help me figure this out.


#8

Actually, you do need to only run the litmus test against ownCloud. SabreDAV is an essential part of any ownCloud installation. No need to install SabreDAV itself. You can just run the test from any PC and it will tell you what does not work ... or whats blocked. Sorry I don't have better instructions for running the litmus test ...


#9

A tutorial how to run litmus is available at [1]. But as the popup in [2] is showing a "405 Method Not Allowed" its probably not needed to run this test as this already shows that the hoster is blocking the needed WebDAV methods.

[1]

[2]