High memory utilization - 9.1.1 on Centos - 2

help

#1

Please help us by providing the following info.
Before posting please also check the pinned "Known issues" threads and
make sure that you're running the latest available version for your oC
release: https://owncloud.org/changelog/

Steps to reproduce
1. Reboot Owncloud server once or twice a day
2. Memory utilization is normal to start with
3. After a few hours mysqld is using a huge amount of memory

Expected behaviour
Memory utilization should remain normal - no reboots necessary

Actual behaviour
Daily reboot required.

Server configuration
OS: Centos 7
Web server: Nginx
Database: Mysql / Mariadb
PHP version: 2.4.0
ownCloud version (see ownCloud admin page): 9.1.1 stable
Updated from an older ownCloud or fresh install: Updated

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):

Integrity status for oC9+

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here.

ps aux --sort=-%mem | awk 'NR<=10{print $0}'

USER PID %CPU %MEM VSZ RSS TTY STAT START TIME COMMAND
mysql
14112 6.4 2.3 1761684 189996 ? Sl 07:25 1:41
/usr/libexec/mysqld --basedir=/usr --datadir=/var/lib/mysql
--plugin-dir=/usr/lib64/mysql/plugin
--log-error=/var/log/mariadb/mariadb.log
--pid-file=/var/run/mariadb/mariadb.pid
--socket=/var/lib/mysql/mysql.sock

This is a virtual server and I have tried increasing memory from 8gb to 16 gb but the issue still occurs.

Thanks

Solved by RealRancor in post #2created33mlast reply17m2replies9views2users3linksRealRancor17mHi,

issues like that should be always reported directly to ://github.com/owncloud/core/issues1

Thanks.Solution

Thanks RealRancor

Correct me if I am wrong but reporting issues to GitHub would imply that there is something wrong with the code.

However in this case I am sure that the issue is more likely to be with my configuration, particularly with mysql. Hence a forum would be the better platform.

Cheers


#2

Hi,

i highly doubt that a high memory usage and running out of memory is a configuration issue. Why are you assuming that?

Memory leaks are the most common issues for such high memory usage and those are not caused by a configuration but by some bugs within the code of a software.


#3

Hi RealRancor

I agree that memory leaks are indeed most often caused by a bug in the software.

However I have only recently started monitoring the memory usage on our OC server and it has previously gone through several OC upgrades in its lifetime (since 8.2).

I cannot be certain that the problem wasn't also present in the previous OC versions running on the server.

Also, my online searches on the issue all seem to point towards a specific config requirement for Mysql in conjunction with Mariadb .. which I was hoping that someone may be able to assist me with since I am not a Linux guru nor am I an expert in Mysql.

I really want to rule out any mistakes in configuration on my part before I start raising concerns about bugs in the software.

Cheers


#4

Only thing I can think of is if you handle file-locking with your sql database. If possible use redis that reduces the load on your database considerably when doing file transfers. You can also monitor your sql server, log slow queries, check if tables got unusually large, ...