How to find webserver or OC logfile / enable php logfile

Most times it’s very useful to have a look at the webserver logfile, the own logfile of ownCloud or the logfile of php. On linux you can find (depending on your used distro) at this locations:

ownCloud (access on the file system directly->Login via ssh-terminal/ftp, NOT via browser):

Please set DEBUG to true (for 8.1 and below):

or debug => true (for oC 8.2+):

and the loglevel to 0:

in your config.php (just add the two directives above) to get more logging output.




Can be located in a separate folder in your home-directory or in the managing-interface of your provider. In doubt, check your webhoster’s FAQ and manual or ask their support.

Source of this info:

The plain PHP installations shows error instead of logging them. To enable the error log of php you have to edit your php.ini (e.g. /etc/php5/apache2/php.ini) and set these options:

display_errors = off
log_errors = on
error_log = /var/log/php-errors.log

Additional you have to create this logfile with the proper permissions:

sudo touch /var/log/php-errors.log
sudo chown www-data:www-data /var/log/php-errors.log

After this edits you have to restart your webserver and/or your php fcgi process.

How to fix Update/Upgrade issues
Unable to download files FROM Owncloud Server over Internet - Gets to around 90% then fails
Owncloud 9.1.1 - new user email notification not work
Cannot use FTP to access files
Issues with upgrade from 8.2.8 to 9.0.5: Undetermined Error during Integrity check
How to fix CalDAV|CardDAV|WebDAV problems
How to fix problems with LibreOffice/OpenOffice previews
Php5-fpm error sock-file missing
Owncloud creates zip file that cannot be opened by file-roller
Installation Owncloud 9.1.0 impossible
Daily calendar look not right
Fedora 25, Nginx, Mariadb
Trouble while installing OwnCloud 9 on Centos
Share Files & LDAP
Dav error updating using updater app, 9.0.019 --> 9.0.4
APCu not available for local and distributed cache
[LOG - Info] Invalid tokens older than DATE
Cannot "repair" my installation in maintenance mode
Federation and desktop client syncronization problem
"Internal server error" after update
External Storage - ReFS Filesystem
ownCloud 9.1.1: "Storage not available"
OC 9.1.0 Mod Rewrite problem (possibly)
Installation 9.1 without creating a new database possible?
Upgrade to 9.1 from 9.0.2
Can't upgrade: CSRF attack warning, then error about major versions
Adminbackend nicht erreichbar
Folder size bug
I cannot login Owncloud 9.0.4
Opendir(/var/temp): failed to open dir: Not a directory
Internal Server Error
Probleme mit Cron nach Update auf OC9.1
[CLOSED/SOLVED]Renaming of already shared folders 9.0.4
Server replied: Insufficient Storage
OC app is enabled but do not work
QNAP Deployment. Large downloads fails >4GB files
MySQL Error 1071 on ugrading from 9.0 to 9.1
MAIL 0.5.2 APP account update problem
Intergity check failed during 8.2 => 9.0 upgrade
Alfresco WebDav External storage
Web login broken. browser ask to download index.php instead of displaying login screen
Cannot write into "config" directory! SELinux issue. Help me, please :-(
Trouble migrating ownCloud to a new server
Issue with versioning on Google Drive
E-Mail Server SMTP Configuration - 550 Relay Error
Duplicate key insert attempts into oc_preferences database object
Darstellung Fehler
Web-DAV/permission issues
Datenupload von Android Handy funktioniert nicht
Teilen Funktion verschwunden
Dav:migrate-calendars and dav:migrate-addressbook not available in 9.1.x?
Selinux issues and php5.4
Odd Occurrance after upgrading to Ubuntu 16.04
Since 9.1 can't share calendars and can't change shared properties
Can't create new files online, can't use online apps
Online editing shared text files
Integritätsprüfung EXTRA_FILE owncloud.log
PDF Download nicht möglich
Set User's Email address with IMAP authentication
OC icon move to the left after ubuntu update on 14.04 - regression from previous issue
Problem with sharing files
Oc.js not accessible
Problem with AD connection via LDAP for some users
Neue Benutzer können alte Dateien nicht öffnen
Cannot upload files larger than 2Gb
Problems upgrading from 7.x to 8.x; php dependency not correctly resolved
Having a lot of problems!
Problem after megration from Ubuntu 14.04 to 16.04
Enable HTTP Strict Transport Security on Ubuntu
404 error from web
9.1.1 RC: Long time to open administrator page
It's failed the integrity check when I update from 9.0.1 to 9.0.4
Unable to change Max upload Limit
CPU auf 100% wenn Share Files(0.10.0) aktiv ist
PHP module GD not installed
9.1 Files Page Not Loading After Login and No Navigation
Password doesn't work after upgrading
Crash after update from ubuntu 14.04 to 16.04
Data Directory Error - Permissions Issue
Fehlermeldung bei cronjob seit Update auf 9.1.0
PHP Fatal error: Uncaught Error: getLogger() (WPOD)
Short cookie validity?
Special options for SMB external stroage
"No such file or directory" error download/synchronized files
Collabora/CODE and Richdocuments plugin error
Owncloud redirect - some issues
Geteilte Ordner: Dateien werden teilweise nicht gesynct
LDAP traffic chaos / duplicate authentications
HTTP Error 500 after upgrade to owncloud 9.1
I cannot delete or rename directory of file
Problem with Owncloud...Internal Server Error Please Help Me!
Webcron Error 404
Encryption won't work
Cannot delete files nor create folders
Owncloud 9.1 MS Office Problem
File link thunderbird without password
LDAP user on sub-sub Active Directory OU not found
Problem with AD connection via LDAP
Share files using email link does not work, link show up white page
Kalender: keine Darstellung im Web-Interface - clients aber ok
Not all users can share calendars
oC samba cache problem 9.0.4 (and under)
Synchronisation vom Desktop Client funktioniert nicht mehr
Key update hunging in "Saving" status
Here is my log from the Windows Sync app
External Storage - No Text Input Fields for entering Folder, etc
Sharing {FILE.NAME} Failed, could not find {remote@email.address}, maybe the server is currently unreachable
OwnCloud seems hungry? Does this look OK?
Upgrade from 8.1.9 to 8.2.7
Can not mount Samba Shares
9.1.1 upgrade error
Internal PDF viewes show only blank pages?
Connection error using wifi
No Home or Upload Button for new Users
Webupdater claims 9.1.0 is the most up-to-date Version
Problem nach Verschieben von Verzeichnisssen
Incorrect link in "Tips & Tricks"
Bugs encoding Russian Cyrillic letters when downloading zip files through the web interface, owncloud 9.1
Problem with Lightning calendar synchronizing
Owncloud in Wartungsarbeiten
No update message from 9.1.0 (stable) to 9.1.1 (stable)
LDAP Users cleanup not working at all
Collabora Online not Work
Owncloud does not import future appointments from ics file
Owncloud 9.1 und Ubuntu 14.04 LTS relase upgrade
Access denied to MariaDB. Any suggestions?
How to re-direct site to always use HTTPS?
OC 9.1 New user not working in IE for Initial Login
Broke my server
High memory utilization - 9.1.1 on Centos
Error in log and throwing internal errors
Migrate Owncloud Server 7.0.4 (on Ubuntu 12.04) to Owncloud Server 9 (on Ubuntu 16.04)
Email in 9.1 not working for non server domains
Apache: Add another site (phpBB3) besides owncloud
Upgrade -> (CentOS)
No rescanning after adding files via FTP or creation via custom script
Fatal Error Upon Upgrading to 9.0.4
Cannot create "data" directory nach update uaf 9.1
Activity notification loop - an email sent to all every 30 minutes
Error occurred while checking server setup
OC neu aufsetzen mit vorhandener DB
No Add button on files page
External Storage Redirect to Homepage
Mapping SMB shares - wildcard folder name based on user ID
Access denied, CSRF check failed
No Mails to external User
No Mail to external User
Hinzufügen von neuen Kontakten in ownCloud nicht möglich
Hinzufügen von neuen Kontakten in ownCloud und PHP 7.0 nicht möglich
Best Practices for performance during Client synchronization
Issue with owncloud and exchange server
Can't Login After Upgrading
Error downloading the list of folders from the server - server replied: Service unavailable
Kein Emailversand über share link
Gallery Plugin active, but .jpg not recognized as media
Can't make folder, delete folder or file but can upload files
Exception while scanning; undefined
Weblogin nicht möglich - Danke fürs Lesen!
Cant add events in calendar in fresh installation of OC 9
Ubuntu 14.04 to 16.04 kills owncloud
No longer able to update 8.x, after adding new repos ended with 9.x that doesn't want to finish the update
Cannot write to some calendars from Thunderbird
Can't sync my owncloud with Windows Desktop client
Scan to OwnCloud with Samsung Copier
Remove /owncloud from URL [SOLVED]
Where do I find Htuser and Htgroup?
Error with zip files
Admin external storage is not user specific
Simple beginner's question: Allowing upload
After Upgraded 9.1.1, old local user can't log in
Linux File Manager auto refresh not working with Owncloud Client
I am having problem to map the user from LDAP on vs 9.0.4 new
Notification Email turn in loop every 15 minutes
Owncloud 9.1.1 and folder permissions Windows server 2008R2 issue (Junction links not working)
Own cloud deleted all yesterday's work on MS Word
LDAP Group problem
Authentication error loop version
OwnCloud 9.1.0 RC1, Using LDAP
QNAP Owncloud von 8.0.4 auf 9.x updaten
Calendar events and Thunderbird
Slow loading data from client
Mailbird on ownCloud
Recover external storage with encryption
Will someone give me some suggestions for tuning a low power consumption server? Much appreciated!
Migration Failled oc v6 to v8 on Synology
WebDAV no longer working after upgrade to 9.1.2
Internal Server Error. Cannot upload most files
Automatisches Verhalten programmieren
OC HyperV Appliance - Cannot figure out how to set 16GB file upload
Permissions when mounting a local folder
Configuration Error (prefix ): No LDAP Login Filter given!
App Icons disappeared out of applauncher after movin to /owncloud subdir
Disconnection when using Windows 7 client
.../owncloud/core/vendor/jquery/jquery-1.10.2.js wurde nicht gefunden
Folder shared twice with user
Contacts Sync issue with oC 9.1 / Thunderbird 43 / SoGo Connector 31.0.3
Apt-get update killed OC
I can't logout in Chrome from my admin acount
Cannot use lexical variable $eventName guzzlehttp
The Client comes online and goes offline every minute or so
Recreating deleted files
Owncloud Server Upload speeds
File locked - .eml in einer Freigabe
Verwaiste Benutzerordner werden nicht gelöscht
Loss of GUI Log In Page after Upgrades & Reboot
Upgrade from oc 7.0 for beginner or rather complete takedown?
oC 9.1.4 adding SFTP external storage doesn't work
Massive GET /status.php requests
OpenBSD error - Too many open files
Bookmarks Not Saving
Uploading of large files fails
User gets a security pop up every time he opens a file
Shared Links broken after upgrade
Automatic apt upgrade from > broken installation
Web Interface Max File Size Upload
Method Not Allowed WebDAV error appears to prevent discovery of addressbooks and calendars
Multiple entries in contacts birthday calendar per person
Hello. Please help solve the problem. I can't download file more than 300 MB. The fix breaks. When you sync the same error. What do I do. I need download video 2 GB
Update troubles using the updater
CSync failed to access and duplicate folders
Update not shown in Updater App
Internal Server Error ("Unable to load dynamic library") - blank login page
Calendar - cannot create or import calendars or events
9.1.4 Kalender freigeben ohne bearbeiten klappt nicht
How to Use occ on Command Line to Disable Two-Factor Authentication and Get Logged In
Desktop Client - Sync entire data folder
Integrity check failed after upgrade
Log in / sign in button does not work
Updated app error / oC 9.0.4 to 9.0.6
Update via Linux Paket-Manager und anschließende manuelle Installation schlägt fehl
Need to Setup Different permissions on LDAP and local users
Can't get passed admin creation screen
Slow upoad speeds from desktop client
MS OneNote 2013 und Owncloud
Owncloud ubuntu appliance has broken php5-libsmbclient
Wie mache ich, dass meine ownCloud mit SSL verschlüsselt ist?
An exception occured in driver: SQLSTATE[HY000] [2002] Can't connect to local MySQL server through socket '/opt/tmp' (111) on latet version 10 (Alpha)
Calendar event notifications
Files:Scan - Help needed
How can I remove the apps button?
Rasberry pi3 owncloud unkonown error
Kalender in Thunderbird
Calendar page empty after upgrade to 9.0.8
Hosted upgrade from 8.2.10 -> 9.0.8 failed - what to do?
Files external storage dont work
Windows client login fails since upgrade from 9.0.2 to 9.1.4
Solved: Exception while scanning: array_merge(): Argument #2 is not an array
Owncloud LDAP replica server issues
Moving files via command line on server in OC 9+
After password reset - Data not Viewable (invalid private key)
Server Protokoll zeigt "Core Error"
Renamed files on read-only local external storage cause "File was deleted from server" error
Kalender teilen nicht möglich
Error PHP Module 'redis'
Fehler beim Einbinden von externem Speicher (Externer Speicher -> lokal)
Error uploading file. Problem loading page, reloading in 5 seconds
HTTP 500 error on fresh install of owncloud server
SMB External Storage not showing files
Files keep comming back
OC 9.0.4 - External Storage, FTP - Daten werden nicht aktualisiert
Windows client does not connect with server
Share link in a owncloud
Install and activate additional PHP modules
External Storage Save in session does not prompt for user login
Owncloudcmd has to run X amount of times to sync the directory
Need a Hand with Collabora Integration
Owncloud 9 not connecting to AD LDAPS
Error deleting file "filename"
Can't edit email address in Ldap users
Install OC 9.1 and connect to an existing db
Syncing is out of sync, and admin account has an odd problem
Pdf is not syncing with owncloud windows client
Trouble Syncing Files
Calendar Import Fails
Zwangsupdate auf OC 9.1.5 - kein Zugriff mehr
Linux Ubuntu Clients not working after upgrade
Locking open file - WebDAV - multiple users
Set users home directory / different then their username
Failed OC server update
Size of unzipped VHDX file?
File share with email error
Calendar sharing does not work since upgrade to 10.0
Internal Server Error - Owncloud
Cannot access my owncloud server
Cannot access my owncloud server
Unable to delete user
Synchronization Bug?
WebUI not showing files even though webdav and other clients are working fine
Get php fatal error when trying to go into owncloud
Freigegebene Kalender nur lesbar
Owncloud Client Mac does not save password
Would like to be able to specify included files
Meine Frage zum Zugriff vom Windows-PC auf Owncloud-Server, der unter Ubuntu im VirtualBox des anderen Windows-PSs installiert wurde?
Owncloud stops working once a week or even more
Internal Server Error after clean install OC10.0.2
Windows Client login fails since upgrade from 9.0.2 to 9.1.4 / 9.1.6
Cannot Log in to web interface after fresh install
Calendar: Event with local participant is automatically added on participant's calendar
Home Ordner synchronisieren
Error deleting last empty folder
Owncloud Encryption
Fresh installation problem
I'm getting a blank page / 500 Internal Server Error
Slow Admin-Page