How to manually install an app in the back end when it fails in app UI?


#1

Please help us by providing the following info. Before posting please also check the pinned "Known issues" threads and make sure that you're running the latest available version for your oC release: https://owncloud.org/changelog/

Steps to reproduce
1. Upgraded OC to latest stable OC 9.1.4.
2. App Share renamer was previously enabled and is disabled after upgrade.


3. When trying to enable app in tools section, get error: Archives of type text/html are not supported

Expected behaviour
Tell us what should happen

Share renamer app should be installed and working.
The app's description says it should be compatible up to ownCloud 9.2.

Actual behaviour
Tell us what happens instead

I get error: Archives of type text/html are not supported.
App cannot be installed.
I have tried downloading the app code directly but have been unable to install manually from the back end, so far.

Server configuration
Operating system: Ubuntu 14
Web server: Apache
Database: MariaDB
PHP version: PHP 5.5.9
ownCloud version (see ownCloud admin page): upgraded to 9.1.4
Updated from an older ownCloud or fresh install: updated
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):

ownCloud log (data/owncloud.log)

Error	core	Archives of type text/html are not supported	2017-03-29T17:17:31+00:00
Error	core	Archives of type text/html are not supported	2017-03-29T17:05:45+00:00
Error	core	Archives of type text/html are not supported	2017-03-29T16:40:35+00:00

Integrity status for oC9+

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here.

#2

Ref to the bugreport at the issue tracker of the app:

which seems to be a duplicate of the following:

Sum-up: You can't use the app store to install this app. Just download the app from https://github.com/fcturner/sharerenamer/releases and place it into your /path/to/owncloud/apps folder and make sure that the folder is called sharerenamer and not sharerenamer-1.1.

Afterwards you can enable the app from the "Not Enabled" category.


#3

After following those steps, I now get: Error: could not disable broken app

Do I need to clear out any entries in the DB before?

select * from oc_appconfig;
...
| sharerenamer | enabled | yes |
| sharerenamer | installed_version | 1.2 |
| sharerenamer | types | |


#4

on a guess, I ran delete from oc_appconfig where appid="sharerenamer"; in the DB to clean up leftover DB entry. After this, I was able to enable the app, and it now works.