How to recover from an accidentally executed unsupported upgrade

8.2.x
9.1.x
help

#1

Hi, I was not paying attention during an OwnCloud upgrade and so I accidentally upgraded from 8.2 to 9.1, instead of 9.0. Now I am stuck with an Owncloud server running in maintenance mode and when I try to get it out of that using the command "sudo -u www-data php occ upgrade" it tells me the upgrade is not supported. Well, I already knew that, but how to get out of this? An ideas?

I'm running on a Raspberry Pi

Thanks,
Douwe


#2

Hi,

there is a FAQ available here explaining the needed steps how to do a correct upgrade and how to recover from such a situation:


#3

Thank you RealRancor,

That was indeed the link I needed. Now I am on 9.0 so upgrading to 9.1 should not be too difficult. I accidentally used the link to the stable release in the sources list....