Installation issue of owncloud client 2.5.2 on Ubuntu 18.10


#1

Expected behaviour

Owncloud Client 2.5.2 should be installed on Ubuntu 18.10 successful.

Actual behaviour

The following packages have unmet dependencies:
owncloud-client : Depends: libowncloudsync0 (= 2.6.0.11073~daily20181128+oc-5) but it is not going to be installed
Depends: ocqt5101-libqt5concurrent5 but it is not going to be installed
Depends: ocqt5101-libqt5core5a but it is not going to be installed
Depends: ocqt5101-libqt5dbus5 but it is not going to be installed
Depends: ocqt5101-libqt5gui5 but it is not going to be installed
Depends: ocqt5101-libqt5keychain1 but it is not going to be installed
Depends: ocqt5101-libqt5network5 but it is not going to be installed
Depends: ocqt5101-libqt5webkit5 but it is not going to be installed
Depends: ocqt5101-libqt5widgets5 but it is not going to be installed
Depends: ocqt5101-libqt5xml5 but it is not going to be installed
Depends: owncloud-client-l10n but it is not going to be installed
Depends: ocqt5101-libqt5sql5-sqlite but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Steps to reproduce

I tried to install owncloud client 2.5.2 on Ubuntu 18.10 by following your instruction:
sudo sh -c “echo ‘deb http://download.opensuse.org/repositories/isv:/ownCloud:/desktop/Ubuntu_18.10/ /’ > /etc/apt/sources.list.d/isv:ownCloud:desktop.list”
sudo apt-get update
sudo apt-get install owncloud-client

Server configuration

Operating system: Ubuntu 18.10

Web server:

Database:

PHP version:

ownCloud version:

Storage backend (external storage):

Client configuration

Client version:

Operating system:

OS language:

Qt version used by client package (Linux only, see also Settings dialog):

Client package (From ownCloud or distro) (Linux only):

Installation path of client:


#2

Hey,

why is your system trying to install a version of the owncloud-client package which isn’t present on your configured repository?


#3

Hi ktl ,

did you use www.owncloud.org ? there is the latest tested version and it is 2.5.1 .
i would recommend this version.
and to install it ,do please following steps :
wget -nv https://download.opensuse.org/repositories/isv:ownCloud:desktop/Ubuntu_18.10/Release.key -O Release.key
sudo apt-key add - < Release.key
sudo apt-get update
sudo sh -c “echo ‘deb http://download.opensuse.org/repositories/isv:/ownCloud:/desktop/Ubuntu_18.10/ /’ > /etc/apt/sources.list.d/isv:ownCloud:desktop.list”
sudo apt-get update
sudo apt-get install owncloud-client


#4

Hi @lazawan (and @ktl)

I see something similar (also (k)ubuntu 18.10) … I tried (there’s some history of uninstalling and so on before) the reinstall like you suggested here (remove all repos, apt-get update, wget Release.key, add key, …)

But, when finally installing the client, I see

$ sudo apt-get install owncloud-client
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 owncloud-client : Depends: libowncloudsync0 (= 2.5.1.10973+oc-10450) but it is not going to be installed
                   Depends: ocqt5101-libqt5core5a but it is not going to be installed
                   Depends: ocqt5101-libqt5dbus5 but it is not going to be installed
                   Depends: ocqt5101-libqt5gui5 but it is not going to be installed
                   Depends: ocqt5101-libqt5keychain1 but it is not going to be installed
                   Depends: ocqt5101-libqt5network5 but it is not going to be installed
                   Depends: ocqt5101-libqt5webkit5 but it is not going to be installed
                   Depends: ocqt5101-libqt5widgets5 but it is not going to be installed
                   Depends: ocqt5101-libqt5xml5 but it is not going to be installed
                   Depends: owncloud-client-l10n but it is not going to be installed
                   Depends: ocqt5101-libqt5sql5-sqlite but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Somewhere it was recommended to install all the dependencies manually, so I tried:

$ sudo apt-get install owncloud-client libowncloudsync0 ocqt5101-libqt5core5a ocqt5101-libqt5dbus5 ocqt5101-libqt5gui5 ocqt5101-libqt5keychain1 ocqt5101-libqt5network5 ocqt5101-libqt5webkit5 ocqt5101-libqt5widgets5 ocqt5101-libqt5xml5 owncloud-client-l10n ocqt5101-libqt5sql5-sqlite 

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ocqt5101-libqt5core5a : Depends: libc6 (>= 2.28) but 2.27-3ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.

Well, libc6 is in fact <=2.28 and not jet a newer one in sight.

Do you have a suggestion?

THX in advance


#5

Hey,

if you have this version of libc6 installed you’re probably using Ubuntu 18.04 and not 18.10:

https://packages.ubuntu.com/bionic/libc6

and should use the 18.04 and not the 18.10 repositories.


#6

THX, @tom42

you’re totally right, I mixed that up … I changed the deb to 18.04 and now everything is fine.