Internal server error on vm


#1

I am running my server off the virstual box premade system using univention and whenever i open owncloud, it has me login and then gives me an internal error:

I'm new to owncloud so please give me a step by step way to fix it.:grinning:


#2

The posted screenshot shows an "More details can be found in the server log". You probably need to find this log on the appliance to know whats wrong here.


#3

I suppose it's because the avatars folder isn't there.

Try this:

get the IP address of your appliance. Then connect to it via ssh. For example lets assume the IP address is 192.168.1.1

ssh root@192.168.1.1
password <-- the password for the administrator you set during the setup of the appliance
univention-app shell owncloud
mkdir -p /var/lib/univention-appcenter/apps/owncloud/data/avatars
chown -R www-data:www-data /var/lib/univention-appcenter/apps/owncloud/data/avatars
exit
reboot

If this does not work, or if you want to try it the way @tom42 suggested - you can log in to your appliance via ssh as described above and search the log for the "Request ID" that is shown in your screen shot of the error.

you can do this like this:

ssh root@192.168.1.1
    password <-- the password for the administrator you set during the setup of the appliance
cat /var/lib/univention-appcenter/apps/owncloud/data/files/owncloud.log | grep "<paste here the request ID>"

Then you would have the exact error message. That would help finding the solution to your problem.


#4

tried the first part but that didn't work. I did the second code and this is what it said:

{"reqId":"fgEGLmq91pL63JIBd04z","level":3,"time":"2017-11-19T06:53:47-06:00","remoteAddr":"xxx.xxx.x.xx","user":"owncloud","app":"index","method":"GET","url":"\/owncloud\/index.php\/apps\/files\/","message":"Exception: {\"Exception\":\"OCP\\Files\\NotPermittedException\",\"Message\":\"No create permission for folder \\/avatars\\/e9\",\"Code\":0,\"Trace\":\"#0 \\/var\\/www\\/owncloud\\/lib\\/private\\/AvatarManager.php(99): OC\\Files\\Node\\Folder->newFolder('e9')\n#1 \\/var\\/www\\/owncloud\\/lib\\/private\\/AvatarManager.php(120): OC\\AvatarManager->getFolder(Object(OC\\Files\\Node\\Folder), 'e9')\n#2 \\/var\\/www\\/owncloud\\/lib\\/private\\/AvatarManager.php(91): OC\\AvatarManager->getAvatarFolder(Object(OC\\User\\User))\n#3 \\/var\\/www\\/owncloud\\/lib\\/private\\/TemplateLayout.php(101): OC\\AvatarManager->getAvatar('owncloud')\n#4 \\/var\\/www\\/owncloud\\/lib\\/private\\/legacy\\/template.php(232): OC\\TemplateLayout->construct('user', 'files')\n#5 \\/var\\/www\\/owncloud\\/lib\\/public\\/AppFramework\\/Http\\/TemplateResponse.php(156): OC_Template->fetchPage()\n#6 \\/var\\/www\\/owncloud\\/lib\\/private\\/AppFramework\\/Http\\/Dispatcher.php(112): OCP\\AppFramework\\Http\\TemplateResponse->render()\n#7 \\/var\\/www\\/owncloud\\/lib\\/private\\/AppFramework\\/App.php(98): OC\\AppFramework\\Http\\Dispatcher->dispatch(Object(OCA\\Files\\Controller\\ViewController), 'index')\n#8 \\/var\\/www\\/owncloud\\/lib\\/private\\/AppFramework\\/Routing\\/RouteActionHandler.php(46): OC\\AppFramework\\App::main('ViewController', 'index', Object(OC\\AppFramework\\DependencyInjection\\DIContainer), Array)\n#9 [internal function]: OC\\AppFramework\\Routing\\RouteActionHandler->invoke(Array)\n#10 \\/var\\/www\\/owncloud\\/lib\\/private\\/Route\\/Router.php(307): call_user_func(Object(OC\\AppFramework\\Routing\\RouteActionHandler), Array)\n#11 \\/var\\/www\\/owncloud\\/lib\\/base.php(928): OC\\Route\\Router->match('\\/apps\\/files\\/')\n#12 \\/var\\/www\\/owncloud\\/index.php(56): OC::handleRequest()\n#13 {main}\",\"File\":\"\\/var\\/www\\/owncloud\\/lib\\/private\\/Files\\/Node\\/Folder.php\",\"Line\":162}"}


#5

Have you tried restarting the appliance?

Also, did you update the appliance or is it a fresh install?


#6

i've tried restarting and it wont let me update


#7

What version were you on, are you on?

Also can you try this:

Edit: If you need help with the commands, just ask away :wink:


#8

How do i set the data directory?