iOS 12, app, Alpha, build 79


#1

2 Issues:

1: indicating the server’s address took some trial and error. I had to add a trailing / for the address to work => The app should be able to find this by itself.

I remember that indicating the server path using the stable app the first time felt rather unhelpful as well so maybe the process is already getting easier but still not easy enough

2: on the stable app, it is not possible to select a large chunk of photos and upload it. Not only there is no “select all” feature but there are other problems: If from Photos, the app will not even propose you to upload the selected photos. If from the app, then the app will crash if you select too many photos.
With the Alpha version I still can not select anything to upload. But when it’s available I hope the p. m. issues with the stable app are addressed.

many thanks


#2

Thanks for your feedback!

I tried to reproduce:

  1. enter cloud.domain.com and click [Continue] or [return] ==> leading https:// and trailing / get added automatically :+1:
  2. enter cloud.domain.com/path and click [Continue] or [return] ==> leading https:// gets added automatically, trailing / doesn’t get added automatically :-1:
  3. entering cloud.domain.com/path/ (with /) finally works

Regarding…

Could you elaborate what needs to be improved in the new app with the path to make it easier?

Only way with build 79 is to go to the “Photos” app, select one or multiple files, then use “Save to Files” feature in the sharing menu and select your ownCloud account there.

Next version will have improvements for photo upload, but “Select all” will need some more time. I think this needs a screen first that let users manage the upload queue, in case “All” is too much. (not enough quota on the server, not enough data left from users mobile provider etc)

Does this answer your questions?


#3

I have 2 accounts in alpha(79)
In one of them i encounter two issues.

When scrolling all the way down takes me to an empty folder and cant hit back .

Another one is when i click on some files this pop up comes up

In my other account i have no issues .


#4

@mavic We’ll release a new beta build with TestFlight later today that should fix the redirect issues.


#5

@chacho Thank you very much for testing and providing feedback. Please test with the new beta build we’ll release later today with TestFlight. If it’s not fixed with the next build, we should have a closer look. We have a debug logging feature of the settings screen. This could help investigating…


#6

I still don’t see new build
Lately having issue logging in


#7

today is not over yet :wink:


#8

build 83 is available for testing :rocket: