Iphone uload size limit

What is the size of the files? I will try to reproduce.

Hallo CScherm

anything larger than 12 MB does not get uploaded. It does not matter if Picture or PDF - it simply does not get uploaded.

Also the upload-feauture sometimes tells me about a “Konfliktfehler”, such as Overwrite existing files as such, but it does not offer the Override-Function always :frowning:

Now i am not sure if I report on a a dead project, as I read about a new Version ?

Kindest regards Lutz Jansen

Have you changed any of these settings?


we are speaking about files with a size <100 MB - no the filesize in the referenced URL have not been changed, hence it works nicely and without any error on any other client such as on Android and Windows PC.

We can isolate this behavior to happen only with the IOS-App … :frowning:

Kindest regards

Ok, then we have to dig deeper. Can you send me the the server log from this request and your ownCloud.log as well?


sure, I only know the owncloud.log, which is located in the \data directory, how can I find the second log to send this to you ?

I will take an average PDF of ~approx 50Mb and reproduce the error for you.

Pls advise

Yours Lutz Jansen


The APP hangs and tries to pump the file up - and the server does not note down anything in the owncloud.log file - so unfortunately no trace on the servier side but complete “hang” on the client side


i think even smaller files might be affected by limits linked in the referenced documentation. This can be seen in e.g. [Resolved] Again the max upload size above 2MB.

1 Like

Hello All

thank you for the hint - we have tested adding the following variables:
‘client_max_body_size’ => ‘16G’,
‘upload_max_filesize’ => ‘16G’,
‘post_max_size’ => ‘16G’,
to our owncloud Config-file. We are on an apache system not NGINX

The result is unchanged - our server runs version

So curious how this proceeds :slight_smile:


i don’t think that the ownCloud config file is the correct place for this configuration. I think everything what is mentioned in the documentation needs to be configured within your web servers configuration.


we have also tried to change the native .htaccess of Owncloud and interjected the desired commands there :frowning:
No Change - it does simply not work with an IOS 12 - unless, there is a better app which knows how to handle Owncloud/nextcloud better … ?
Android (4.4, 7,8,9) they all work and Online browser and Windows-PC-Client - absolutely no issue

Happy to Setup a Video-Conf with sombody, who is able to run an upload from IOS to a Owncloud Server with bigger files - and succeeds :slight_smile:


maybe you can try to explain what you have tried to input into the .htaccess to change the upload limits?

As our Server runs PHP 7 see the respective Chapter:-)

php_value upload_max_filesize 16G php_value post_max_size 16G php_value client_max_body_size 16G php_value memory_limit 512M php_value mbstring.func_overload 0 php_value default_charset 'UTF-8' php_value output_buffering 0 SetEnv htaccessWorking true



i’m asking because there seems to be various other known configuration options listed in the documentation where i don’t think that you can configure those within the .htacces:


From what i know its also not guaranteed that things configured within the .htaccess is always respected by the web server.

Hello Tom42 an other interested

we have assessed the additional tweaks, you kindly forwarded. We do reach a definition-space, by which our system-admins consider other risks appear such as DoS. We tried it temporarily, but it did not work. :frowning:

Secondly we tried to use plain Safari on IOS12 and the webgateway, to check the capabilities here and it works nicely - so we have to assume the problem lies within the OC-App for IOS.

I realized, that there is a parallel redesign/release happening? - So I am happy to wait, until the beta-test for this upgrade includes uploading larger files.

I can live with the cumbersome workarround using the Safari-Browser on IOS just to manage the Information needed to be synchronized.

For the case, that sombody is able to use your IoS-App 3.8.0. (fd012a4) on IoS 12.1 with larger files successfully to be uploaded - I am more than happy to invest more time and try to understand, what we could adopt to make this tool work as designed. :slight_smile:


if you think this is an issue within the IOS app itself then i think you could open an issue at https://github.com/owncloud/ios/issues.

From what i know the forums here is mostly frequented by users (like me). I think the chances that issues which needs to be fixed somewhere in the code of ownCloud or its apps and which are reported in this forums are getting lost are quite high.

This issue seems to be known already - white space

1 Like

All - I strongly suggest to use the “App” called Nextcloud for Apple IOS - works on IOS like a charm. Cost free and fully functional


@lujansen would you like to try again with the new, blazing fast ownCloud iOS app?

For testing, just open this link on your device:

Plan is, to make it available for free in the App Store next week…

1 Like