Is external storage data being shortened?


#1

Hi!
I have a fresh install of owncloud 10.0.8. Previously, I had a 10.0.8 installed from a 9.x, but it had some issues and I decided to make a fresh install.

In the nonfresh 10.0.8, previously configured local storage worked, but newly configurated local storage did not.

In the fresh 10.0.8, local storage does not work.

BUT
I had seen that, when I click on the red line of the non-working local storage, the config line has shoretened: when I said the local storage was in /public_html/BLAHBLAH/BLAH, now the local storage config says “/public_h”

(I can’t check it using the database. I have selected postgres as database type, and I don’t know how to browse a postgres database. phppgadmin says the oc tables about external mount contain 0 rows).


#2

This was removed for security reasons, the admin role should not be able to bring code into the system which is possible with this feature. It can be enabled in config.php. https://doc.owncloud.org/server/10.0/admin_manual/configuration/files/external_storage/local.html


#3

Yes, I’ve enabled it – I’m the only user, I’m root and I prefer to use my owncloud credentials instead of my web hosting credentials when I access my server from my workplace.

But folder names are being shorted. i’ve checked it on the database. But fixing it in the database does not allow it to work.


#4

OK. Issue fixed once I allowed PUT requests. It seems the config uses PUT requests as file manager does.