Issue on upgrade ownCloud 9.1.4 to 9.1.8

upgrade
9.1.x
hosting
webserver_issue

#1

I am using File transfer method to upgrade owncloud version 9.1.4 to 9.1.8. I have moved all files and folders exclude “data” and “config” folder and going to hit URL then its start updating but after some point to update then it certainly stops and gives me the following error:
“Some files have not passed the integrity check”.

And on the admin side its also showing same issue.

Hope someone understands that issue and help me to resolve it.

Looking forward to your response sooner.

Best Regards


#2

There is a link “List of invalid files”. Open it to see the list.


#3

Once I have tried to upgraded and revert again old files & folders then its going way. but when I am trying to update version that time it’s showing “code integrity check”.
Right now I have add
‘csrf.disabled’ => true,
‘filelocking.enabled’ => false

due to upgrade put on maintenance and csft showing error on after logging. but upagrade is unsuccessfuly.


#4

Do you have that List of invalid files or not?


#5

No I don’t have list of invalid files.


#6

Would you please click on the link “List of invalid files” close to the “integrity-message”.


#7

Now on the admin side showing me the above warnings.


#8

DONT DO THAT! This is plain dangerous!


#9

Okay let me remove it.


#10

I have removed it, could you please help me how to fix code integrity check issue when I am doing upgrading.


#11

Please try to read the docs!

https://doc.owncloud.org/server/latest/admin_manual/issues/code_signing.html?highlight=integrity#fixing-invalid-code-integrity-messages


#12

Ok, let me have a look.


#13

Now in admin side showing me this.


#14

Could you please help me how to access my database using phpmyadmin because I have go over but did not find database related to owncloud?


#15

Hey,

personally i think if you want to run a software like ownCloud you should be capable to read and understand the provided documentation of it. Both messages seems to provide a link to the “security tips” and “documentation” where you can find additional info.

If you don’t understand the provided resources then i think you can ask specific questions in a new thread as both seems to be unrelated to the initial and now solved integrity message.


#16

I am facing an issue when I am going to upgrade version so my question is related to that.

When I am doing the upgrade then get error message code integrity so I can’t understand how to resolve that.


#17

I fully agree with @tom42!

@mjmadmin As I don’t see a minimal try to accept the offered help, I’m stopping here. Trying to help in this thread is completely useless and a waste of time. Sorry.


#18

let me do update process again and send you screenshot.


#19

Please don’t stopping post here I really need help to update version.