LDAP Authentication OwnCloud / Zentyal

ldap

#1

Hi,

I recently installed Zentyal in a computer to go as a server. More recently, I installed OwnCloud in another computer to be kind of a OwnCloud server. I want my “office” to login without having to always put their passwords. However, I can’t authenticate LDAP. In the OwnCloud User Authentication page it appears Host, Port, User DN, Password and One Base DN per line. I’ve tried it many ways.
What information should I put in each parameter?

Informations about my Zentyal Server:

  • 2 Network Interfaces: 10.0.0.1/255.255.255.0 (Internal) and 192.168.1.100/255.255.255.0 (External). Range of the Internal - .50 to .99. Range of the External - .150 to .199
  • 2 Gateways: 192.168.1.254 (default) and 10.0.0.254
  • DHCP is activated with the 2 Network Interfaces, with both being with Search Domain as the Zentyal Server
  • DNS is 1.1.1.1

Regards,
Neoscopio

Steps to reproduce

  1. Install OwnCloud
  2. Install LDAP Integration and activate it
  3. Configuration of LDAP

Expected behaviour

LDAP configured and everything running

Actual behaviour

Base DN not found.
Check credentials.

Server configuration

OS: Zentyal (Server I want LDAP to work on)

Web server: Apache2

ownCloud version: 10.0.3 (according to the web server)

Where did you install ownCloud from: owncloud.org


#2

Check your credentials. Try the tool “ldapsearch”. It’s a commandline tool. If you get it working with that tool, ownCloud will work with the same credentials / settings too.


#3

Hey,

i think it maybe could also make sense to use a more recent version of ownCloud as this looks heavily outdated to me.

Additionally maybe reading the documentation on the LDAP configuration available below could give you some answers what information should be put in each parameter:

https://doc.owncloud.org/server/10.0/admin_manual/configuration/user/user_auth_ldap.html


#4

Hi,

Thanks for the quick response. I’ve tried that, nothing. It doesn’t work…


#5

Hi,

Sorry, I will change this, but my OwnCloud version, according to the web server, is 10.0.3.
I’ve tried upgrading it but it doesn’t work. I didn’t install the Appliance one, but the Linux Packages…