LDAP user and group backend app is missing [oC 10.0]


I think it was a surprise for most people :confused:

ownCloud 10 itself is working fine. It's always bad to have breaking changes, but you can't avoid that if a project improves. It's pretty cool to move more and more apps that have been part of the core to the marketplace because every app can get improvements independent and the core stays more tiny.

1 Like

That is a small consolation for the people who got the upgrade during the window when it was live. I agree with your statements that a first major release should never be considered for enterprise use, but that doesn't negate the fact that it happened to some of OwnCloud's customers and now they're stuck with it since downgrading isn't supported either.

I'm glad to finally see someone admit that OwnCloud 10 was not yet ready for production and therefor should never have been pushed to the stable channel.

That is very nice in theory. Some time back calendar and contacts were part of core, since then they are independent and the development is up to the community (to be fair: there has been quite some support by owncloud developers but the priority was very low compared to when it was in core). During ome time there were two different contact and calendar apps (the plus-apps) but it was based on the work of a single developer who didn't have time to continue the development. With OC 9.0 all *DAV went into core and the apps had to be rewritten. After the fork of Nextcloud, they have more development on the calendar app and the ownCloud community does not even manage to backport these improvements.

But the release is totally decoupled from the core releases. And that's the best on it.

Disclaimer: This is my personal opinion. I'm not related in any way to ownCloud or the company.

Is someone working at the LDAP-APP? Didn't find a github repo for that.
Can I test some beta?

The github repo for that app is available here:

Thanks for your fast reply! So it's the same repo as before the marketplace was introduced?
I will try it, maybe it works already, although it seems not much activity there.

UPDATE: not working :disappointed_relieved:

Thank you for this. I upgraded to ownCloud 10 from 9.1 and saw that the LDAP app wasn't there. I installed this new version and it works just fine.

That are good news! Can you elaborate on how to do this, please?
[Solved: Download, extract, change owner, enable with 'occ']

You are right, it's working indeed! I forgot to enable it after cloning the git:
So for everyone: first clone the app into your owncloud apps-folder, mostly /var/www/owncloud/apps

  1. sudo git clone https://github.com/owncloud/user_ldap.git
  2. and activate it with: sudo -u www-data /var/www/owncloud/occ app:enable user_ldap

Et voilà LDAP is working again. I wonder why it needed several days to find this simple workaround :smiley:

I made a zip of all the files on GitHub by pressing clone or download, extracted them to the apps folder within ownCloud in the folder "user_ldap", then enabled it in the Apps menus on the ownCloud control panel from the web interface.

What simsasaile did is a little faster.

It seems to work, but I'm not sure, if something is different. My users-table in admin view only gets populated, after a user has logged in. Many users are "missing" now. And the email field is sometimes empty, sometimes not. It should get populated by ldap query on mail attribute. It did work with 9.x.
I tried changing cache time, but that did not work. Any ideas?

Same here it's working but the Users only shows people who have actually logged in. At first I thought it was because the AD group I added had more than 1000 members, owncloud logs complains about this, not sure if related though
..."app":"PHP","method":"POST","url":"\/index.php\/apps\/user_ldap\/ajax\/wizard.php","message":"ldap_search(): Partial search results returned: Sizelimit exceeded at \/var\/www\/html\/owncloud\/apps\/user_ldap\/lib\/LDAP.php#255"}

Someone suggested to wait for the marketplace version to come out

I reverted back to 9.1.5. All good now. Next time I do an "apt-get upgrade" I'll look very closely, if there is anything related to ownCloud.

From what I understand from the issues on Github for this app, you still need to manually perform a users:sync action with the occ command after configuring an LDAP backend.

The github version of the user_ldap still needs to be taken with care because of this statement:

Please also note that the user_ldap is currently under a major rework and a new improved version should be available in 3-4 weeks.

-> https://central.owncloud.org/t/owncloud-causes-100-cpu-on-ldap-samba4-server/7459/2

If you heavily rely on the user_ldap then you might need to consider to revert to your oC 9.1.5 backup for now.

Thanks for letting us know. I'd love to have a more specific time frame so that I have something to tell my boss. But this is better than nothing.

I don't see how the link you provide is related though. It's about OC 9.

If they would have a more specific time frame they probably have already told us.

The link is about oC 9 but as there is no rewrite of the user_ldap for oC 9 done that guy probably just mixed up something between the versions.